1998 Chrysler Town and Country P0171 code

Tiny
ICEPARROT
  • MEMBER
  • 1998 CHRYSLER TOWN AND COUNTRY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 213,000 MILES
I have a 98 Chrysler Town and Country with 213k miles.

Transmission was replaced 1.5 years ago, and serviced in January '10.
Thermometer on overhead console became hihgly inaccurate Feb '10.
Breaks were replaced 6mm front breaks currently, 4-5mm rear breaks currently. (Spring '10)
Put a portable (cigarette lighter style) 400 watt converter in car for travels,
but only ran it with a monitor, and a phone (drawing like 30 watts max)
Gas Guage broke, and was registering as 3/4 full, when near empty (were at Flagstaff in hot weather)
(tried to fill up at gas station, and had to "force" the gas in. (The pump kept turning off)
Next morning, gas guage worked again.
Major service done Spark plugs, all filters changed, all fluids changed (July '10)
ABS light and Trac off light came on, restarted, and light remained off.
Another Oil Change August '10
Gas guage broke again, car stalled on Freeway, could not get it re-started with fuel from AAA
Replaced Fuel Pump (August '10) They said it had 3/4 tank of gas, (they gave me car back with 3/4 tank)
Driving over the grapevine, the gauge said the car was overheating. We pulled over, and car was not "hot"
restarted, and car dropped to normal temp instantly.
Car started having random drops of RPM and Check Engine Soon light came on (and is ALWAYS on)
Car stalled at slow speeds when RPM was low. (1-2 times a week)
ABS light and Trac off light come on when driving randomly. (Restart car, and it goes away)
Had codes run, P0171 came up. System too lean bank 1. Tech checked for vacuum leaks and found no vacuum leaks.
Tech checked 02 sensor readings and found front 02 sensor switching the voltage to 0 voltage while driving.
Replaced front 02 sensor.
unplugged battery from car, all tempreture gauges seem to work fine now.
However, gas mileage is still low (12mpg) car runs rough at idle, and oil light flickers at times,
has random drops in RPM, and random dinging when at slow speeds and turning corners.
Service Engine Soon light will not go off, and am still getting ABS light turning on.

Mechanic at shop that replaced O2 sensor reccomends getting the PCM flashed.
Dealership that has the ablity to flash wants to do more "testing" before they will "agree"
to flash.

What would you reccomend?
Do you
have the same problem?
Yes
No
Tuesday, November 16th, 2010 AT 8:48 PM

4 Replies

Tiny
DOCFIXIT
  • EXPERT
With that milage I agree with Dealer more testing like compression, injector flow rate and fuel pressure. O2 is not going to cause 171.
Was this
answer
helpful?
Yes
No
Tuesday, November 16th, 2010 AT 9:14 PM
Tiny
ICEPARROT
  • MEMBER
But what about all the problems with the temperatures and the ABS lights?
Was this
answer
helpful?
Yes
No
Tuesday, November 16th, 2010 AT 9:16 PM
Tiny
DOCFIXIT
  • EXPERT
That is why more testing is needed or ypou will end replacing every part on car
Was this
answer
helpful?
Yes
No
Tuesday, November 16th, 2010 AT 10:05 PM
Tiny
ICEPARROT
  • MEMBER
So, you don't think it is PCM? Even though a lot of the problems were resolved when disconnecting the battery?
Was this
answer
helpful?
Yes
No
Tuesday, November 16th, 2010 AT 10:12 PM

Please login or register to post a reply.

Recommended Guides