1998 chevie Lumina running very rough.

Tiny
JUNGLEGEORGE
  • 1998 CHEVROLET LUMINA
  • 6 CYL
  • 156,000 MILES

I have a 1998 Chevie Lumina and about a month ago I experienced an issue where the car after driving a mile and half from my house began to buck and stalled twice before I pulled off the road. I had a burning smell in the cab, possibly electrical. After looking under the hood, I didn't detect anything unusual and the odor that I smelled in the car, I didn't get while checking the engine, I looked under the vehicle and there were no apparent links and so I waited a few minutes and started the car and drove back home, during the journey, it was running rough all the way back to my house and since then, I have used the car, it starts fine, but runs very rough and does not have the power it had since this episode occurred recently, any suggestions, please let me know.

Do you
have the same problem?
Yes
No
Friday, July 22nd, 2011 AT 11:43 AM

2 Replies

Tiny
AUSERNAME123456
  • MEMBER

Sounds like it just needs a good tune up. Change the spark plugs, fuel and air filter. Also check all the fuses something must have shorted out if you smell a burning inside the car.

Was this
answer
helpful?
Yes
No
Friday, July 22nd, 2011 AT 12:56 PM
Tiny
HMAC300
  • EXPERT
  • 45,711 POSTS

Check for engine codes or a vacuum line that fell off. Also check the fuel pressure, it may be low.

Was this
answer
helpful?
Yes
No
Sunday, July 24th, 2011 AT 3:33 PM

Please login or register to post a reply.

Other Engine Runs Rough Questions