Check-Engine Code reads P0441 and P0450

Tiny
TOYOTA GUY
  • MEMBER
  • 1997 TOYOTA T-100
  • 254,000 MILES
Engine runs rough and smooths out as the engine warms up.
Do you
have the same problem?
Yes
No
Friday, January 6th, 2012 AT 11:15 PM

10 Replies

Tiny
HMAC300
  • EXPERT
441 is a evap code meaning it's not getting vacuum or the cannister is messed up 450 is evap as well but could mean the ecm is bador thhe valve is bad. If the canister isn't getting vacuum, fix it and clear the codes as that may cause both.
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:45 AM
Tiny
TOYOTA GUY
  • MEMBER
Would either error codes cause the engine to run rough (like a piston is not firing) than smooth out a few munites later (like all is fine with the engine)
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:49 AM
Tiny
HMAC300
  • EXPERT
If you have a vacuum leak yes that's why I said to check to see if the system is leaking vacuum like aline off. You will have to clear the codes after fixing the problem.
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:53 AM
Tiny
TOYOTA GUY
  • MEMBER
Where is the charcole canaster on the T-100?
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:55 AM
Tiny
HMAC300
  • EXPERT
By the gas tank
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:55 AM
Tiny
TOYOTA GUY
  • MEMBER
Along with the vacuum lines?
Was this
answer
helpful?
Yes
No
Saturday, January 7th, 2012 AT 12:56 AM
Tiny
HMAC300
  • EXPERT
Here is a pic of 3.4L engine. You didn't give engine size so others will be similar easy to look for.
Was this
answer
helpful?
Yes
No
+1
Saturday, January 7th, 2012 AT 1:01 AM
Tiny
EXTREAMHELIS
  • MEMBER
Did. You ever figure this out I have the same problem?
Was this
answer
helpful?
Yes
No
Thursday, August 10th, 2017 AT 9:52 AM
Tiny
KEN
  • ADMIN
Hello,

The user never got back to us on this so we will need to find out whats going on. Here is a guide that will help us start some easy testing.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

and

https://www.2carpros.com/articles/engine-vibration-at-idle

Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, August 14th, 2017 AT 8:52 AM
Tiny
EXTREAMHELIS
  • MEMBER
  • 1997 TOYOTA T-100
  • 3.4L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 143,000 MILES
I have codes po441 and po450 has anyone else had these two codes and got it figured out? Please advise.
Was this
answer
helpful?
Yes
No
Monday, August 14th, 2017 AT 8:53 AM (Merged)

Please login or register to post a reply.

Recommended Guides