I WAS DRIVING AND IT STOPED RUNNING

1997 Pontiac Transport

Tiny

BigMatt321

October, 1, 2011 AT 6:47 PM

I have a 1997 pontiac transport I got one of those hand held machines it told me that the camshaft sensor was bad so I replaced it and it started up then when I went to take it for a test drive I went to give it some gas and it stalled and quit running again can you help please I dont have the money for a shop anything you can do to help would be great thank you and God bless matt

FOUND 1645 RELATED QUESTIONS

Cam Sensor

72 ANSWERS
2 IMAGES

16 Answers

Tiny

cadieman

October, 1, 2011 AT 6:57 PM

RENT A FUEL PRESURE GAUGE FROM THE PARTS STORE. HOOK IT UP AND CHECK THE PRESSURE.

Tiny

BigMatt321

October, 1, 2011 AT 7:20 PM

The fuel pump is fine what else could it be?

Tiny

BigMatt321

October, 1, 2011 AT 7:35 PM

Sorry about that yeah I replaced the fuel first it still didnt run and ive ran the fuel all the way up to the injectors, and thats what it bwas doing before getting all the way to there then nothing is there another sensor that might need to be breplaced maybew like the crankshaft position sensor thank you very much God bless matt!

Tiny

cadieman

October, 1, 2011 AT 10:44 PM

Try starting fluid or gas in the throttle body under the air filter pour or spray in there to see if it starts. If it starts its a fuel issue if not it spark or injecters. Buy a cheap test light and check for spark on wires also check the enjecters for for pulse with. When you touch the test light to the injecter harness the light will flash as you turn the motor over.

Tiny

BigMatt321

October, 1, 2011 AT 10:48 PM

Thanks I will try that stay close I may need you again lol!

Tiny

BigMatt321

October, 2, 2011 AT 4:18 PM

Hey remember me I was wondering if you could help me again ok if I'm getting fuel to the injectors what would cause them not to spay fuel cause if I squirt gas in there like you said it will start but won't stay running could that be a bad regulator or crankshaft sensor it's the injectors something causing them not to work thank you and God bless Matt!

Tiny

cadieman

October, 2, 2011 AT 5:26 PM

Check the fuel pump and injecter fuses

Tiny

BigMatt321

October, 3, 2011 AT 2:25 PM

Where would the injector fuses be thank you god bless !

Tiny

BigMatt321

October, 3, 2011 AT 2:29 PM

If it's not the fuses what else could it be thank you!

Tiny

BigMatt321

October, 3, 2011 AT 2:31 PM

Last question then I will leave you alone could a bad EGR cause it nor to run

Please login or register to post a reply.

Camshaft Angle Sensor Replacement P0015
How to read codes Chevrolet Blazer
How to gather codes Ford Explorer
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Scion XD
 Step by Step video GMC Yukon XL 2000-2006