Car starts only with gas pedel to floor but sputters than stalls within a few secs

Tiny
CHAZ1983
  • MEMBER
  • 1997 PONTIAC SUNFIRE
  • 120,000 MILES
On way home car stalled an wouldnt start I towed it home change fuel filter checked to see if it start with starter fluyid in air intake no luck checked for spark had spark I than learned I could start car if I held gas pedel to floor it started ruffly would stall if I let go of pedel but even if I held pedel to floor it would barely run an spudder a few secs an stall I think got my auncle to run a scan test it said crackshaft position circuit "p0335a" an also a ignition coil modules 24 times red circuit too many pulses "p0121b" so I put a new cranck shaft sensor in an put a new ignition module an coil packs an it is still doing the same thing please help this is my only car an I have to get to work plus get kids around to places they got to go to
Do you
have the same problem?
Yes
No
Thursday, January 12th, 2012 AT 5:41 AM

39 Replies

Tiny
RASMATAZ
  • MEMBER
Got spark and starter fluid is used and no combustion occur-recheck the ignition system and also the fuel pressure
Was this
answer
helpful?
Yes
No
-1
Thursday, January 12th, 2012 AT 3:04 PM
Tiny
CHAZ1983
  • MEMBER
My car is a 97 sunfire 2.2 an I took out ignition moduler an coils an had tested at advance it failed 3 stages so I got a new ignition moduler an coils also I replaced the crank sensor and spark plugs an still the car starts only with pedel to floor an runs ruff an dies although now it does run a few secounds longer lol idk gfot my auncle to bring back ob 2 scan tester to check for codes now only one code last p0121b which is for throttle body sensor but im told by my auncle reguardless it should run with or without the tbs working so we both puzzled an my auncle a head mechanic also I will add while starting car there is a smell of gas like maybe its geting flooded which explains why I got to hold gas pedel to floor to even start it but lost dont know what to do
Was this
answer
helpful?
Yes
No
Wednesday, January 18th, 2012 AT 1:44 AM
Tiny
RASMATAZ
  • MEMBER
Check the coolant temperature sensor and fuel pressure
Was this
answer
helpful?
Yes
No
Wednesday, January 18th, 2012 AT 10:37 AM
Tiny
CHAZ1983
  • MEMBER
Coolant temperture good dont have a way to check fuel pressure but have replaced fuel filter an while it was off did turn key to make sure the pump was pumping fuel an it did I also now replaced the throttle postion sensor since I got code p0121 but no change am I expost to clear the code p0121 after installing tps to get new one to work or should it automaticly work
Was this
answer
helpful?
Yes
No
Monday, January 23rd, 2012 AT 4:22 PM
Tiny
RASMATAZ
  • MEMBER
Try clearing the code if it continues to comeback adjust the TPS voltages and again check the fuel pressure -
Was this
answer
helpful?
Yes
No
Monday, January 23rd, 2012 AT 9:46 PM
Tiny
CHAZ1983
  • MEMBER
My car has a tps that cant be adjusted but my auncle did test voltage an was told it was normal an so was my fuel pressure so realy dont got a clue what to do guess my auncle wants me to try another igntion moduler one I put on it was used but off a car that ran so unlikely its the problem but got nuttin better to try
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 3:23 AM
Tiny
CHAZ1983
  • MEMBER
Also just cleared all coded with a obo 2 computer an the p0121 (tps)hasnt came back but yet the car still doing same thing after I put new crankshaft new tps new fuel filter an used good ignition moduler so now no codes but car still only starts with pedel to floor an than barely runs very low rpms for 30 secs till it stalls only thing I thought of but hadnt tryed was a compresstion test but everyone insisting that aint the problem
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 3:30 AM
Tiny
RASMATAZ
  • MEMBER
Give me a fuel pressure readings before I continue to respond
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 3:57 AM
Tiny
CHAZ1983
  • MEMBER
I should add one thing I got a ignition moduler off my aucle that was took off a used engine that ran an since I was lost couldnt find out why it aint running I took the used moduler to advance they tested it an said it failed two things idk my original one failed 3 things got another one from my auncle an it failed its weird they both came off runing cars is advance test wrong or do I just need to spend the 300.00 for a new moduler I realy dont got 300 bucks to spend but if thats what it takes to fix my car than I got no choice but weird thing is I have spark an everything with all 3 igntions I tryed if it was realy bad it just seems like there should be spark my car shouldnt start at all
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 4:21 AM
Tiny
CHAZ1983
  • MEMBER
Sorry the fuel pressure was 43 with the key turned to the on postion
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 4:36 AM
Tiny
SATURNTECH9
  • EXPERT
Just to add to this if you have spark I would say the ignition module is working atleast at that point. You need fuel pressure and injector pluse to run. So you said you the correct voltage for the tps. Are you taking about the 5 volt refrence going into it?If so you still have to see what it reads back to the computer with a closed throttle wide open throttle etc. If I were you I would be trouble shooting that tps code first.
Was this
answer
helpful?
Yes
No
Tuesday, January 24th, 2012 AT 6:13 PM
Tiny
CHAZ1983
  • MEMBER
Well I deleted all code tryed to start it checked codes all that remained was igntiol moduler 24 times red circut too many pulses deleted code tryed agiain code came back tryed starting it with starter fluid because today is a realy warm day but stil;l didnt start I checked for spark its dark outside an seen all spark plugs has gret spark I finaly got to check comnpresstion comprestion is good every cylinder was 150 while trying to start sp compression is good so I check obo2 again even after trying to start car for over 2 hours no new codes except the one I stated at begining of message but at least the crankshift sensor an tps codes aINT COMEING BACK SINCE BOTH BEEN REPLACED now I am waiting for my auncle to bring a noid light to check injector pulse I will be able to tell you how that goes real soon
Was this
answer
helpful?
Yes
No
Thursday, February 2nd, 2012 AT 2:01 AM
Tiny
SATURNTECH9
  • EXPERT
So what is the exact code number you have now?
Was this
answer
helpful?
Yes
No
-1
Thursday, February 2nd, 2012 AT 2:14 AM
Tiny
CHAZ1983
  • MEMBER
Well did the noid light on the injectors and they pulse an work good so thats good an the obo says the following exactly word for word ( ignition coil module 24 times red circuit to many pulse ) so what does that mean I tryed searching the internet about what its saying but had no luck
Was this
answer
helpful?
Yes
No
Friday, February 3rd, 2012 AT 5:03 PM
Tiny
SATURNTECH9
  • EXPERT
You are reading me the code description. What is the exact code number?It will be a P followed by a four digit number?Thats what I need from you to get you a trouble tree for it.
Was this
answer
helpful?
Yes
No
+1
Friday, February 3rd, 2012 AT 5:37 PM
Tiny
CHAZ1983
  • MEMBER
Well I had a guy at advance use the proper way to test the igntion module an it passed perfectly so I got new coils no change as far as the code ill have to get that from my auncle I only wrote down the discription next to the code an I was talked into buying a new fuel pump reguardless the pressure was tested an was good but of course it didnt change things I will get you the igntion code as soon as I can
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 2:08 AM
Tiny
CHAZ1983
  • MEMBER
I thought I'd add a few things befor car died it use to stall randomly about 1 or 2 a month but would start an run great afterward also when I got the car a year ago the antifreeze looked real dirty water I changed it a few months back an it been green ever since two question I got could I have a blown head gasket or a timeing belt tentioner problem them both was my first though befor having it looked at an was told that most likely ain't the problem since I was getting codes an everything else I check was good as far as spark fuel an compression so I don't know what to do next I know you want the ignition module code an I will have you it soon as I talk to my auncle but was hoping to get a answer on a blown Moter or timing chain basically would it start at all if it's blown gasket or if the timing chain tentioner is broke an how do I check these two things or would both my ideals be a waists of time
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 3:38 AM
Tiny
SATURNTECH9
  • EXPERT
A compression test would tell you how the timing was. The code I think you have is for the crank sensor. Get me that code and let me know what it is and we will go from there.
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 5:25 AM
Tiny
CHAZ1983
  • MEMBER
I orIgaly had a p0121B witch was a crankshaft sensor It was only ten bucks so I replace it an the code never came back so far orIgaly I had a p0121b crankshaft sensor a Po335a tps sensor an the code that says ignition modules coil 24x r circuit too many pulse so far I change tps cranksensor ignition module coils fuel pump I had fuel pressure at 42 had compression 150 each cylinder an so far still same problem only starts with pedal to floor an runs at extremely low rps while still holding pedal to floor than it stall the crankshift an tps codes is code but the unknow code that says ignition coil module 24x r circuit too many pulses I got good spark good compression an good fuel pressure I also noir check the fuel injector an it also works perfect I don't know what to do next or where to go I did look up code definitions an by description the code should be p1370 which says ignition control modular 4x ref too many pulses when is the dame discription as mine except mine is 24x instead of 4x I assume it has to be that code no other says anything about too many pulses an the circuit part so if that will help u help me if not I'm still trying to get ahold of my uncle to get the forsure code basically everthing on my car is bran new or texted to be good except water pump timing chain alternator an a few sensors like map an another one
Was this
answer
helpful?
Yes
No
Monday, February 6th, 2012 AT 7:40 AM
Tiny
CHAZ1983
  • MEMBER
Also I Would like to think u for all ya help so far my car might not be fixed but at least I ruled out slot of things by now I wish I would of junked the car for 300an used the 700 I spent in parts an I would of had a 1000 to spend on a car well now I really got no choice but to fix I spent 1000 for it put 1500 in it to pass inspection only to break down an put 700 in it an still same problem I had a month ago I know I'll never buy another sunfire parts expensive on it an it's a money pit but hope to here what ya think after reading my post befor this one think you so much I am greatful
Was this
answer
helpful?
Yes
No
Monday, February 6th, 2012 AT 7:50 AM

Please login or register to post a reply.

Recommended Guides