Hello I have a petrol 1.6 Astra 1997. The motor runs at idle but will not increase revs

Tiny
DOUGLAS MCCONNELL
  • 1997 OPEL ASTRA
  • 136,000 MILES

The problem started about 1 month ago and since then the car has stood idle. Petrol and air filters have been replaced.

Do you
have the same problem?
Yes
No
Monday, February 13th, 2012 AT 7:07 PM

8 Replies

Tiny
FIXITMR
  • MEMBER

Any engine warning lights on? Take a fuel pressure test?

Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 7:11 PM
Tiny
FIXITMR
  • MEMBER

What happens when you try to increase throttle?

Was this
answer
helpful?
Yes
No
Monday, February 13th, 2012 AT 7:20 PM
Tiny
DOUGLAS MCCONNELL
  • MEMBER

Hello thanks for the response to my question. No warning lights on and when I open the throttle the revs stay the same, however this morning whilst fiddling I removed the wire to the (acceleration sensor) I think, and after plugging and unplugging this a few times the revs came up but the idle stayed high. Once switched off back to the same.

Was this
answer
helpful?
Yes
No
Tuesday, February 14th, 2012 AT 8:54 AM
Tiny
FIXITMR
  • MEMBER

Is the throttle plate clean?

Was this
answer
helpful?
Yes
No
Tuesday, February 14th, 2012 AT 8:26 PM
Tiny
DOUGLAS MCCONNELL
  • MEMBER

I will strip today and check thanks, I have wiped in there and quite a bit of dirt was on the rag.

Was this
answer
helpful?
Yes
No
Wednesday, February 15th, 2012 AT 4:31 AM
Tiny
FIXITMR
  • MEMBER

When you said 'open throttle' did you mean move throttle plate? Do we know if it's responding to pedal?

Was this
answer
helpful?
Yes
No
Wednesday, February 15th, 2012 AT 5:20 AM
Tiny
DOUGLAS MCCONNELL
  • MEMBER

Hi the throttle plate responds, I did a complete strip and washed out the throttle plate and complete unit. I refitted using a new stepper motor Idle unit and managed to get the motor running. The revs took a while to pick up but then the idle was fine. I took a run for about 20 kms and all was fine except a little flat until the revs were up. I have ordered a Tps (Throttle position sensor) and when that arrives in the morning I will fit it and see. Thanks again, appreciated.

Was this
answer
helpful?
Yes
No
Wednesday, February 15th, 2012 AT 4:51 PM
Tiny
DOUGLAS MCCONNELL
  • MEMBER

Hello all the fault was with my crank gear. Key way on shaft was partially stripped. Replacement gear was R100 and car revved up normally.
Thanks forthe advice.

Was this
answer
helpful?
Yes
No
Saturday, February 25th, 2012 AT 7:20 PM

Please login or register to post a reply.

Other Engine Idle Low Questions