"New" 1997 olds 88 help!

Tiny
SHAFA1121
  • MEMBER
  • 1997 OLDSMOBILE 88
  • 6 CYL
  • FWD
  • AUTOMATIC
Bought a used 1997 olds 88 with 80K last week. Said it was misfiring (blinking CEL) because he used a refurbished "rotor". I took that to mean distributor rotor, which would equate with the coil packs on my car. The car has been sitting in the guy's driveway for 2 years. The car drove rough, but still drove well on the highway (I live 2 hours away). Engine was still loud, etc, but the ride was smooth. CEL always on and blinking at a steady pace. Pulled the belt off to replace and the pulleys are rusty. Going to take a wire pad to them and hope that gets rid of most of it until I can buy new pulleys. Anything ideas on how to get the engine running smoother? Have replaced plugs and wires, will do CP if that doesn't fix it. Really hoping it's not the cat. Checked oil, no metal in it. I know the question of why I even bought the car will come up, I got a good deal on it. $1,000 3800 engine with 80K, needs a little work but for that deal I am willing to do it. Just need a little help getting there.
Do you
have the same problem?
Yes
No
Saturday, June 18th, 2011 AT 1:02 PM

5 Replies

Tiny
WRENCHTECH
  • EXPERT
You may think you got a good deal but may find out otherwise. The guy lied to you to start with since it doesn't even have a rotor. This could be a lot more serious like like a ead gasket or bad head but it needs to be diagnosed correctly.
Was this
answer
helpful?
Yes
No
Saturday, June 18th, 2011 AT 1:38 PM
Tiny
SHAFA1121
  • MEMBER
He told me he "doesn't spend a lot of time around engines" when I asked him if it took 10-W 30 oil, so it could be an honest mistake. He said he took it in to get codes and it was a misfire of sorts. Even a head gasket replacement will still be cheaper overall than what I would pay for a similar car. Planning on taking it to get codes pulled, but going to finish plugs and wires first.
Was this
answer
helpful?
Yes
No
Sunday, June 19th, 2011 AT 1:23 AM
Tiny
SHAFA1121
  • MEMBER
Got the plugs and wires swapped out, the car is running smooth in park or at lights. Noise quiets when braking. CEL isnt blinking anymore, but it solid. I think it may be a fuel problem? I noticed taking a corner that it had started flashing again and I know the gas gauge in the car is sensitive to movement like that. Does that pretty much mean its a fuel problem?
Was this
answer
helpful?
Yes
No
Monday, June 20th, 2011 AT 10:17 PM
Tiny
SHAFA1121
  • MEMBER
NO check engine light! Going in for an oil change so my guys can check it out, might need a new wheel bearing, but thats still better than the other possibilities.
Was this
answer
helpful?
Yes
No
Wednesday, June 22nd, 2011 AT 4:03 PM
Tiny
WRENCHTECH
  • EXPERT
Closing question
Was this
answer
helpful?
Yes
No
Thursday, June 30th, 2011 AT 11:36 PM

Please login or register to post a reply.

Recommended Guides