Excessive high idle speed

Tiny
JOSE BRANDI
  • MEMBER
  • 1997 MITSUBISHI MONTERO
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 223,000 MILES
Hi,
My montero '97(3.0 - 12 valves) have a high idle speed(at start 1500 rpm and increase maintaining in 2,000 rpm. No sound is detected from the IAC (idle air control step motor). This device could be damage? This malfunction arose inmediatelly after cleaning the throttle body and timing change. The valves are open, leak or bend? With the key in on position and stop engine the load value is in 78 % is supose to be on 0%. No OBD II codes area shown. What happen? How may pinpointing the fail?
Do you
have the same problem?
Yes
No
Friday, January 7th, 2011 AT 3:25 PM

5 Replies

Tiny
JOSE BRANDI
  • MEMBER
Clarification. Timing belt change
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 3:27 PM
Tiny
MMPRINCE4000
  • EXPERT
Recheck the timing belt marks, if advanced too much it will idle high.

But for the most part an idle that high is a vacuum leak.
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 3:30 PM
Tiny
JOSE BRANDI
  • MEMBER
Thanks!
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 4:03 PM
Tiny
JOSE BRANDI
  • MEMBER
I foget one detail. After the timing belt installation, I start the engine with out connect the throttle body hose tube. This action could incorrect lern the PCM? And set incorrect IAC value?
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 4:14 PM
Tiny
MMPRINCE4000
  • EXPERT
Yes.
Was this
answer
helpful?
Yes
No
Wednesday, January 19th, 2011 AT 3:46 PM

Please login or register to post a reply.

Recommended Guides