.

  • Tiny
  • Dazras
  • 1997 LINCOLN CONTINENTAL
  • 135,000 MILES

Hi. After starting engine, it will run rough for a second then stall. I can get it started if I rev the engine right away and hold the pedal halfway down and the engine will run rough for about 30 seconds then it will be fine. This only happens after a hot soak of 30-45 minutes on warm or hot days. There's no vacuum leaks and the idle air valve was replaced recently. Thanks for the help!

Do you
have the same problem?
Yes
No
Friday, October 19th, 2012 AT 1:28 AM

5 Replies

  • Tiny
  • Dazras
  • MEMBER

I also forgot to mention there's no codes or check engine light. Thanks!

Was this
answer
helpful?
Yes
No
Friday, October 19th, 2012 AT 1:32 AM
  • Tiny
  • Rasmataz
  • MEMBER

Understand No code/s- Try cleaning out the EGR valve and also the MAF sensor with its cleaner and see what happens-recheck the IACV

Was this
answer
helpful?
Yes
No
Friday, October 19th, 2012 AT 1:40 AM
  • Tiny
  • Dazras
  • MEMBER

How do I clean them out? Do I have to remove them from the engine first? Which cleaner do I use? Thanks!

Was this
answer
helpful?
Yes
No
Friday, October 19th, 2012 AT 2:21 AM
  • Tiny
  • Rasmataz
  • MEMBER

You have to remove the EGR valve and use solvent or Carb cleaner/bore brushes-clean out all the ports as for the MAF sensor -get an electronic cleaner or buy the MAF sensor cleaner

Was this
answer
helpful?
Yes
No
Friday, October 19th, 2012 AT 8:41 AM
  • Tiny
  • ASEMaster6371
  • EXPERT
  • 25,554 POSTS

I would also verify the fuel pressure.

Roy

Was this
answer
helpful?
Yes
No
Friday, October 19th, 2012 AT 11:41 AM

Please login or register to post a reply.

Other Idle Air Control Valve IAC Leak Questions