. AFTER STARTING ENGINE IT WILL RUN ROUGH FOR A...

1997 Lincoln Continental

Tiny

dazras

October, 19, 2012 AT 1:28 AM

Hi. After starting engine, it will run rough for a second then stall. I can get it started if I rev the engine right away and hold the pedal halfway down and the engine will run rough for about 30 seconds then it will be fine. This only happens after a hot soak of 30-45 minutes on warm or hot days. There's no vacuum leaks and the idle air valve was replaced recently. Thanks for the help!

FOUND 4 RELATED QUESTIONS

5 Answers

Tiny

dazras

October, 19, 2012 AT 1:32 AM

I also forgot to mention there's no codes or check engine light. Thanks!

Tiny

rasmataz

October, 19, 2012 AT 1:40 AM

Understand No code/s- Try cleaning out the EGR valve and also the MAF sensor with its cleaner and see what happens-recheck the IACV

Tiny

dazras

October, 19, 2012 AT 2:21 AM

How do I clean them out? Do I have to remove them from the engine first? Which cleaner do I use? Thanks!

Tiny

rasmataz

October, 19, 2012 AT 8:41 AM

You have to remove the EGR valve and use solvent or Carb cleaner/bore brushes-clean out all the ports as for the MAF sensor -get an electronic cleaner or buy the MAF sensor cleaner

Tiny

ASEMaster6371

October, 19, 2012 AT 11:41 AM

I would also verify the fuel pressure.

Roy

Please login or register to post a reply.

How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear
Code Read Retrieval/Clear Scion XD
Read Codes Like a Pro