INJECTORS NOT PULSING? AND NO POWER TO THE FUEL PUMP/RELAY

1997 Isuzu Rodeo

Tiny

nckiolb

March, 3, 2012 AT 8:38 PM

On my way home from washing the motor down after replacing the waterpump, It just suddenly died. After getting it home, I checked the fuel pump and I'm getting no power. I checked the fuses and the relay. I'm also not getting any power to the fp relay when placing the key in the "on" position. I would spray starter fluid and it would run shortly so I'm getting spark. I then jumped the fp relay just to prime the motor to see if I could get it to run and it still wouldn't start. I have replaced the computer and still does the same thing. I checked the key ignition harness and it seems alright. I'm on the brink of torching this thing. Any help would be much appreciated.

FOUND 94 RELATED QUESTIONS

2 Answers

Tiny

fixitmr

March, 3, 2012 AT 8:44 PM

Any engine sensors in area you washed? How did you wash it?

Tiny

nckiolb

March, 3, 2012 AT 9:45 PM

Pretty much washed everything with a pressure washer. It's been sitting for about 6 months now and I just got it running. Let it idle about 20min and it ran very well. I went to put it in gear and drove about 10 feet and died. Checked the fuses and the 15a "engine device" fuse was blown. I replaced it and it fired back up. And went to put it in reverse and it blew. Now as soon as I put the key in the "on" position it blows. Why would it be doing this now?

Please login or register to post a reply.

Replace Your Fuel Pump Relay - Easy Steps
Replace Fuel Pump Relay
Fuel Pump Replacement
Fuel Pump Replacement Done Right