Trouble starting

Tiny
ROBERTGMC97
  • MEMBER
  • 1997 GMC C1500
  • V8
  • 2WD
  • AUTOMATIC
I have a 1997 GMC Sierra 1500, I have replaced the b
attery, the alternator and the starter truck draws to start
but starts after I turn it off it will not start
Battery is charged
Do you
have the same problem?
Yes
No
Monday, June 20th, 2011 AT 1:28 AM

4 Replies

Tiny
RASMATAZ
  • MEMBER
Got check engine light?

Do below to determine if its a fuel or spark problem

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine at least 3/16 away from ground -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if so, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it.
Was this
answer
helpful?
Yes
No
Monday, June 20th, 2011 AT 1:58 AM
Tiny
ROBERTGMC97
  • MEMBER
Well I finally got it started but as soon as I turn it off it does the same thing, now my speedometerneedle is stuck at 100mph and it wouldn't start I notice a cliking sound by the driver side under the hood my cluster shows everything normal I've tested the battery with my multimeter and shows 12.56 dcv but still will not cranck I don't know what to do now it idles high even after driving it.
Was this
answer
helpful?
Yes
No
Monday, June 20th, 2011 AT 3:33 AM
Tiny
RASMATAZ
  • MEMBER
Clean out the idle air control valve and test the MAP and TPS sensors-also look for vacuum leaks
Was this
answer
helpful?
Yes
No
Monday, June 20th, 2011 AT 3:40 AM
Tiny
ROBERTGMC97
  • MEMBER
Ok, I tested the MAP and the TPS on the TPS I got 6.17vdc from the gray wire to the neg batt. Give or take my multimeter has not been calibrated in a while also as a mived the throtle by hand I saw it increased 1.49 to 5.12 dcv when I get it to start everything looks good no high idel everything good as soon as I turn it off it wouldn't start I turn the key and it has the synt of a bad starter drags to cranck and th only way I can get it to work again is by charging the battery as soon as I turn the truck off it goes to the same thing all over again. It has new alt, new batt and new stater and I just change the oil I don't know what else to do but to take it to a mechanic. But I would like to know wtf is wrong with her. Thank You for ur time and i'll stay in touch with u
Was this
answer
helpful?
Yes
No
Tuesday, June 21st, 2011 AT 1:41 AM

Please login or register to post a reply.

Recommended Guides