Engine runs rough, will not idle

Tiny
KMCCONAUGHEY
  • MEMBER
  • 1997 CHEVROLET LUMINA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 124,977 MILES
I just replaced the lower intake manifold gasket. I know the push rods are in the correct location and the firing order is right. It runs really rough. I suspect the fuel injectors. What do you think
Do you
have the same problem?
Yes
No
Friday, January 28th, 2011 AT 11:15 PM

6 Replies

Tiny
WRENCHTECH
  • EXPERT
It sounds like you didn't have this problem before so why would the injectors suddenly have a problem. Make sure you are correct about the push rods as they are slightly different between intake and exhaust. Make sure you have correct plugs on the injectors also.
Was this
answer
helpful?
Yes
No
Friday, January 28th, 2011 AT 11:59 PM
Tiny
KMCCONAUGHEY
  • MEMBER
It ran fine when I took it apart. The fuel rail came out really hard and went back in hard. What do you mean when you say ( have the correct plugs on the injectors )? The push rods are about a 1/4" dirrerent. The shorter ones go to the intake and longer on the exhaust.
Was this
answer
helpful?
Yes
No
Saturday, January 29th, 2011 AT 12:30 AM
Tiny
WRENCHTECH
  • EXPERT
Do you have the right wires going to the right injectors.
Was this
answer
helpful?
Yes
No
Saturday, January 29th, 2011 AT 12:51 AM
Tiny
KMCCONAUGHEY
  • MEMBER
I have checked and rechecked the wires and the harness connectors are all different. None are the same pin type. I layed the fuel rail off to the side when I tore it apart. I did take the fuel back off and changed all the o-rings. I also changed the spark plugs since they were in for a while. It seems to be vaccume or electrical.
Was this
answer
helpful?
Yes
No
Sunday, January 30th, 2011 AT 10:44 PM
Tiny
WRENCHTECH
  • EXPERT
I don't know what you're looking at but all of the injector plugs are identical except for the wire colors.
Was this
answer
helpful?
Yes
No
Sunday, January 30th, 2011 AT 11:09 PM
Tiny
KMCCONAUGHEY
  • MEMBER
I never disconnected the wires from the injectors. I left the wires on the fuel rail and layed it back next to the hood on the drivers side fender well
Was this
answer
helpful?
Yes
No
Sunday, January 30th, 2011 AT 11:23 PM

Please login or register to post a reply.

Recommended Guides