Gas Gauge to work improperly?

Tiny
CUSO
  • 1997 CADILLAC STS
  • 130,000 MILES

1997 Cadillac sts 4.6 If I hooked up the two black wires on my fuel pump wrong, would this cause the gas Gage to work improperly?

Do you
have the same problem?
Yes
No
Wednesday, February 29th, 2012 AT 8:37 PM

9 Replies

Tiny
RASMATAZ
  • MEMBER

The gray wire is the power to the fuel pump and black goes to ground- dunno where the other black wire goes-no wiring diagram for the fuel sending unit-sorry

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 8:54 PM
Tiny
CUSO
  • MEMBER

There are two blacks a gray and a purple

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 8:56 PM
Tiny
RASMATAZ
  • MEMBER

Did you replaced the fuel pump?

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 9:17 PM
Tiny
CUSO
  • MEMBER

Yes I replaced it

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 9:19 PM
Tiny
RASMATAZ
  • MEMBER

Double check the wiring from the connector to the fuel sending unit

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 9:46 PM
Tiny
CUSO
  • MEMBER

Could it be a bad connection or something?? Is that what you think happened?

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 9:48 PM
Tiny
RASMATAZ
  • MEMBER

Dunno, you just have to backtrack your work if its working prior to replacing the pump-

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 10:11 PM
Tiny
CUSO
  • MEMBER

The Gage dis work prior to replacing the pump. By the way thank you for your help. Does this seem like a wiring issue or maybe the float?

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 10:15 PM
Tiny
RASMATAZ
  • MEMBER

Open it up and recheck wiring and float resistances

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 10:23 PM

Please login or register to post a reply.

Other Instrument Cluster Gauge Fuel Level Questions