COULD MY CONNECTOR THAT GOES TO THE SENSOR BE BURNED?

  • Tiny
  • Checks38
  • 1997 CADILLAC STS

I was driving a week ago had the aircondition going and all of asudden the aircondition cuts off, then I started to smell chlorine maybe something burned. When that happen the car want read the coolant level. Like when I change the waterpump and when I started up the car it use to tell me to check coolant level now it dont.

Do you
have the same problem?
Yes
No
Tuesday, August 30th, 2011 AT 12:39 PM

3 Replies

  • Tiny
  • Wrenchtech
  • EXPERT
  • 20,564 POSTS

You had a message to check coolant level and you continued to drive it anyway? There is a good chance that you have fried it now. Pressure test the cooling system and find out where the coolant is going.

Was this
answer
helpful?
Yes
No
Tuesday, August 30th, 2011 AT 1:05 PM
  • Tiny
  • Checks38
  • MEMBER

No I didnt have a check coolant level what i'm saying is my I wont to no if my sensor or the connector that plug in to the sensor is bad. When the water level gets to certain level the message comes on i'm not losing any coolant.I change my waterpump I drain the coolantso when I drain the coolant to change the waterpump and after I put it in and crunk up the car should have said check coolant level but it didnt why is that.

Was this
answer
helpful?
Yes
No
Wednesday, August 31st, 2011 AT 12:48 AM
  • Tiny
  • Wrenchtech
  • EXPERT
  • 20,564 POSTS

Have the sensor checked.

Was this
answer
helpful?
Yes
No
Wednesday, August 31st, 2011 AT 12:50 AM

Please login or register to post a reply.

Other Engine Stall Questions