1996 Dodge Neon Instrument panel

Tiny
STUDIOCHID
  • MEMBER
  • 1996 DODGE NEON
  • 86,000 MILES
The instrument panel intermittently works. Speedometer, tachometer both zero out while driving. Then suddenly return working?
Is this a sensor problem, a connection problem or do I need a new instrument cluster or computer?
Do you
have the same problem?
Yes
No
Thursday, August 8th, 2013 AT 3:17 PM

1 Reply

Tiny
CJ MEDEVAC
  • EXPERT
I HAVE A '95

GOT A DEAL ON IT, IS THE ONLY REASON I BOUGHT IT. IT WAS "SUPPOSED TO BE" MY WIFE'S AND I'S "SPARE CAR"

I GAVE A WHOOPING $250 FOR IT IN 2005. IT HAD 52,000 MILES. PERFECT INTERIOR. GREAT A/C.30 MPG. ONE SMALL DENT DOWN THE DRIVER'S DOOR

. IT WAS "BORROWED" BY MY EVIL STEP-DAUGHTER FOR 4 YEARS WHILE SHE "GOT BACK ON HER FEET". INTERIOR IS NOT REAL GREAT NOW. SHE FOUND THAT THE CAR IN FRONT OF HER MADE AN EXCELLENT BRAKING DEVICE WHILE SHE TEXTED HER BUDDIES

. BUT IT'S OK. NEITHER CAR WAS HER'S!

IT'S "OURS AGAIN"."ONE MUST GET OFF THEIR BUTT. TO GET ON THEIR FEET".I MADE THE HOOD GO BACK IN PLACE. MY FRIEND SAYS, IF IT COULD HAVE ONE, IT WOULD HAVE A "BLACK LUNG", AS IT IS LIKE RIDING IN AN ASH TRAY WITH WHEELS NOW. REAR STRUTS ARE LACKING

.A/C STILL WORKS AND 30 MPG.I DID THE OIL CHANGES, MYSELF, ALL ALONG, I HAVE INSTALLED ONE O2 SENSOR. AND A BATTERY

. MAYBE I CAN GET "MY MONEY OUT OF IT, AFTER ALL"!

I HAVE FOUND THAT BY REMOVING THE INSTRUMENT CLUSTER UN-PLUGGING THE CONNECTIONS

THEN "EVER-SO-SLIGHTLY".(JUST A HAIR) BENDING THE MALE PINS IN THE CONNECTORS,

WILL MAKE THEM CONTACT THE INSIDE OF THE "FEMALE" CONNECTORS BETTER

BEND 'EM TOO MUCH, AND THEY'LL FOLD OVER WHEN PLUGGED BACK TOGETHER

I WAS "SLAPPING" THE DASH TO MAKE THEM COME ON. GOOD TO GO NOW!

I ONLY DRIVE IT NOW, TO KEEP THE BATTERY UP. AND STILL BE A GOOD, "MY CAR WON'T CRANK.I'LL DRIVE 'LIL RED TO WORK"!

I HAVE 2 JEEPS THAT I'D RATHER DRIVE!

THE MEDIC
Was this
answer
helpful?
Yes
No
Saturday, August 10th, 2013 AT 11:44 AM

Please login or register to post a reply.

Recommended Guides