1996 Chevrolet S-10 tried everything

Tiny
JERRYDSIZE44
  • MEMBER
  • 1996 CHEVROLET S-10
  • 2.2L
  • 4 CYL
  • RWD
  • MANUAL
  • 235,000 MILES
Truck will go into gear only when off when engine is running will not go into gear bought brand new clutch kit master cylinder put it all in brand new and it still does the same thing tried just about everything but still wont go into gear when the engine is running I have bled the clutch so now im at a loss I have no more ideas on what it could be I need help
Do you
have the same problem?
Yes
No
Saturday, October 25th, 2014 AT 8:36 PM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Clutch kit. Is that the clutch disc, pressure plate? Also, did you replace the slave cylinder?
Was this
answer
helpful?
Yes
No
Saturday, October 25th, 2014 AT 8:50 PM
Tiny
JERRYDSIZE44
  • MEMBER
Yes the clutch kit comes with the disc pressure plate throwout bearing and flywheel and I replaced the slave cylinder which for my truck is called a master cylinder for some reason my truck is a 96 but has all 95 parts on it for some reason its a 96 cause it was made in the 12th month but the built it with all 95 parts the 96 doesnt have the forks n arm inside the bell housing but yes everything is replaced all new and it wilk go into gear when engine is off but no gear when engine is on I had a drill bit as the push rid to engage and disengage the clutch before I replaced slave cylinder in whixh it could be that the new push rod isnt long enough to push the arm or the arm is nit locked into place but I have tried everything n that is possible becayse when the engine is off there is no presseure but when the engine is on there is pressure but really im not sure
Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2014 AT 1:47 AM
Tiny
WRENCHTECH
  • EXPERT
You just don't have the air bled out yet. It can be very difficult because the bleeder is at the bottom and the air tends to rise to the top. You may need to have it pressure bled.
Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2014 AT 3:57 PM
Tiny
JERRYDSIZE44
  • MEMBER
Yeah u bled it but had to push back the rod in the slave cylinder to get it to push in and out up against the arm so I thought it was fixed I drove it took gears well took a test drive soon as I pulled up at the house the rod blew out of the slave cylinder and a piece came off so now the rod is in there somewhere probably gonna have to pull the trans for the 4 th time in two weeks to get the rod and the arm done moved too soits becoming a real headache and im goin to have to replace the brand new slave cylinder I just bought now I have three slave cylinders three clutches pressure plates and throwout bearings and all of this started because I had to to replace the flywheel its ridiculous and I find out my truck is a 96 but has all 95 parts because it was made in the 12th month of 95 it has all 95 parts I called gm gave them the vin and guess what they dont even habe a record of the truck what a mess
Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2014 AT 4:39 PM

Please login or register to post a reply.

Recommended Guides