Heater/AC fan stopped working

Tiny
SGREGORY
  • MEMBER
  • 1995 SATURN SL2
  • 168,000 MILES
I played around with the power harness located under the dash and it makes it work if you push it one way or the other but then immediately starts acting up and dieing down if not shutting off completely. Please help its so cold
Do you
have the same problem?
Yes
No
Wednesday, January 4th, 2012 AT 7:48 PM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
Sounds like you have a open terminal on one of terminals to the blower motor. Unplug the blower motor look at the terminals they should both be closed if they are you need a new blower motor. If your unsure post a pic of connector terminals for me to see.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 7:54 PM
Tiny
SGREGORY
  • MEMBER
Is that what you'd consider open?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 8:07 PM
Tiny
SATURNTECH9
  • EXPERT
I cant see the plug can you post a pic so I can see the connector?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 8:10 PM
Tiny
SGREGORY
  • MEMBER
Can you see it now?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 8:58 PM
Tiny
SATURNTECH9
  • EXPERT
Yeah especially the one on the left side in the pic. Take a small pick and bend the tab closest to the connector tab towards the lock tab to close it do both sides. Then plug it back in and see how it works. Let me know how it works.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 9:05 PM
Tiny
SGREGORY
  • MEMBER
Made a difference foe a minute or two but I think I did it wrong is there any way I could safely cut off the harness and put two individule conectors on?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 9:28 PM
Tiny
SATURNTECH9
  • EXPERT
Why do you think you did wrong can you show me a pic of what it looks like now?The blower motor itself could have a loose connection with the terminals coming off the motor I have seen that before.
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 9:33 PM
Tiny
SGREGORY
  • MEMBER
If it is the blower motor is it hard to get it out?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 9:52 PM
Tiny
SATURNTECH9
  • EXPERT
You did it wrong you bent the whole connector over to other side it needs to be pushed back where it was when you started. Picture this that terminal is folded over and there is a gap at the opening of the terminal you insert the pick and bend the folded over part to close the opening. Try it again and post a pic of your results. To remove the blower motor its three 5.5mm screws holding in place. Also is that connector melted or iam just seeing things?
Was this
answer
helpful?
Yes
No
Wednesday, January 4th, 2012 AT 10:08 PM

Please login or register to post a reply.

Recommended Guides