Car runs fine then starts to sputter a bit and stalls

Tiny
BBC_JOEY
  • 1995 NISSAN ALTIMA
  • 200,000 MILES

Time varies sometimes it takes 5 mins other times it takes 40.

The car runs fine, Other than the described problem.
I replaced the Fuel filter(a lot of dirt came back out of it), The distributor cap(It had a crack in it). I was thinking to replace the ignition coil.

It seems to run fine, drives smooth no missing or roughness, UNTIL whatever happens it starts to sputter and hesitate a bit then shuts off I still have power(battery is new also even cleaned off the corrosion) just the engine seems to shut off. It seems to not shut off sometimes when I mash the gas but its only a temporary thing adds a few mins till it happens again.

I took the tubes off the fuel filter and turned my key (not on but turned to start fuel pump) and gas came out so I don't think it's my fuel pump, Though I don't know It could be I'm far from knowledgeable on cars. I've put dry gas in my tank and fuel injection cleaners in my tank in-case it was dirty gas or water in the tank nothing seems to fix it.

Do you
have the same problem?
Yes
No
Thursday, June 14th, 2012 AT 6:50 PM

6 Replies

Tiny
BBC_JOEY
  • MEMBER

I also ran the car alot after I changed the filter to make sure the dirt was outta the lines.

Was this
answer
helpful?
Yes
No
Thursday, June 14th, 2012 AT 6:52 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

Check the spark plugs. If they are sooty, you could hae a fault with the ECT.
Have you checked for trouble codes?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, June 14th, 2012 AT 7:00 PM
Tiny
BBC_JOEY
  • MEMBER

I don't have a way to get the codes, The auto stores around here have computers that hook up to 96 and up nothing for 95. The spark plugs seem to be firing I help them against the motor and could hear them firing, they were dirty themselves around the outside a lil bit as for inside I didn't look.

Was this
answer
helpful?
Yes
No
Thursday, June 14th, 2012 AT 7:21 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

http://www.2carpros.com/articles/nissan-obd1-diagnostic-trouble-codes-and-retrieval-procedure-1984-to-1994

Check out the above link.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, June 14th, 2012 AT 9:17 PM
Tiny
BBC_JOEY
  • MEMBER

Code 325 I think. Had to have GF watch the lights blink since the CHeck engine light blinks and the screw was on the floor.

I think thats the knock sensor? What is my next step?

Was this
answer
helpful?
Yes
No
Thursday, June 14th, 2012 AT 11:27 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,939 POSTS

Yes, for Nissan any problem with the knock sensor can rsult in hesitation. It also commonly fails and you need to replace it to rectify.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Friday, June 15th, 2012 AT 5:19 PM

Please login or register to post a reply.

Related Engine No Start Questions

Help us by donating