Car seems to run fine only when slightly.

Tiny
JEREMYCARLSON
  • 1995 MAZDA 626
  • 194,000 MILES

Car seems to run fine only when slightly pressing the accelerator peddle (10% throttle or so). However when pressing it down further, starts losing spark in all cylinders and sputters. Shop thinks it's a distributor problem, already ruled out ECU (replaced, same problem).

Distributor or possibly a throttle position sensor of some kind?

Do you
have the same problem?
Yes
No
Monday, December 10th, 2012 AT 11:01 PM

5 Replies

Tiny
HMAC300
  • EXPERT
  • 45,719 POSTS

Scan for codes and check fuel pressure first. Clean grounds on left front and side of engine as well. It migh tnot be making good contact. Easier to do before distributor replacement.

Was this
answer
helpful?
Yes
No
Monday, December 10th, 2012 AT 11:12 PM
Tiny
JEREMYCARLSON
  • MEMBER

No check engine light is being thrown, would it still throw a code in that case?

Was this
answer
helpful?
Yes
No
Monday, December 10th, 2012 AT 11:13 PM
Tiny
HMAC300
  • EXPERT
  • 45,719 POSTS

Fuelpressure wont' throw a code and will cause engine to run lean feelling like your condition fuel pressure should be 30-37 psi at idle w/vacuum an d 38-46 w/o vacuum

Was this
answer
helpful?
Yes
No
Monday, December 10th, 2012 AT 11:20 PM
Tiny
JEREMYCARLSON
  • MEMBER

Ok. Also when I press the throttle slightly it will rev all the way up to redline (while in neutral) if I let it. Only there is a very specific point that I reach on the throttle when the ignition cuts out.

I should restate, with a timing light connected it is clear that the ignition is cutting out with the throttle pressed further down. I don't believe it's a fuel issue.

Was this
answer
helpful?
Yes
No
Monday, December 10th, 2012 AT 11:53 PM
Tiny
HMAC300
  • EXPERT
  • 45,719 POSTS

Then check the distributor or replace it and see if it changes. It may be a bad cam sensor init or reluctor.

Was this
answer
helpful?
Yes
No
Tuesday, December 11th, 2012 AT 12:10 AM

Please login or register to post a reply.

Other Throttle Position Sensor TPS Replace/Remove Questions