GMC JIMMY FUEL PRESSURE PROBLEM

  • Tiny
  • Kvn4
  • 1995 GMC JIMMY
  • 255,886 MILES

95 GMC JIMMY 256885 miles 4.3 vtec had erratic idle for couple of days. Cleaned iac valve this am now have crank no start. Checked fuel pressure koeo 60psi then drops to zero after 2 sec. A/c delco fuel pump put in 8months ago was getting tps code also. No start

Do you
have the same problem?
Yes
No
Monday, April 2nd, 2012 AT 1:54 PM

15 Replies

  • Tiny
  • Djcl
  • EXPERT
  • 786 POSTS

Check voltage @ starter

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 2:09 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,984 POSTS

Title had been truncated. Can you please elaborate?

If you had sprayed carb ceaner into the throttle body, it would definitely make it hard to start, at least for a while.

The fuel pressure driopping to 0 after 2 seconds indicate the fuel pump is working but you have a leak in the system. It could be from the fuel delivery line and intank or the fuel pressure regulator is bad.
Try clamping the return hose and testing the pressure to see if it drops, if yes, you would need to check the fuel pump side. If pressure does not drop, replace the fuel pressure regulator.

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 2:09 PM
  • Tiny
  • Kvn4
  • MEMBER

Had tps code yesterday with eractic idle but car started no problem. Cleaned iac valve this am and now have no start even with starter fluid. Checked spider area inside intake and just wet no gas smell. Tried startind seems to want to start but doesnt catch.

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 2:36 PM
  • Tiny
  • Kvn4
  • MEMBER

Any pics of fuel return hose. Or instructions. Thanks k

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 2:39 PM
  • Tiny
  • Djcl
  • EXPERT
  • 786 POSTS

Ee if the plugs are soked might be flooded

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 2:42 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,984 POSTS

Is your system CPI or TBI? For TBI the pressure dropping to 0 when ignition is turned off is correct.

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 3:14 PM
  • Tiny
  • Kvn4
  • MEMBER

Cpi pulled one plug and gunked up and wet. Shall get new ones tonight when wife gets home as stuck for now. Is best way to change them to go through wheel wells. Will do tomorrow and let you guys know. Thanks again k

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 3:50 PM
  • Tiny
  • Wrenchtech
  • EXPERT
  • 20,567 POSTS

You're symptoms are pointing to a leaking fuel injector assembly. The early Vortecs were notorious for that.

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 3:58 PM
  • Tiny
  • Kvn4
  • MEMBER

Changed plugs (i hate doing the left side) started right up but back to my high idle. Have code for the tps, could that be my problem or something else causing code. Money very tight but if you think should replace ill go with your advice.

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 8:54 PM
  • Tiny
  • Djcl
  • EXPERT
  • 786 POSTS

Yes a bad tps can cause a hi idle. Can you check the voltage on all 3 wires and let me know what thay are with key on

Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2012 AT 10:48 PM

Please login or register to post a reply.

Other Fuel System Pump Pressure Questions