Broke vents?

Tiny
JIMMYEDWRD
  • MEMBER
  • 1995 CHEVROLET ASTRO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 250,000 MILES
My vents arnt working only the defrost one in the dash is working
Do you
have the same problem?
Yes
No
Wednesday, November 17th, 2010 AT 3:02 PM

3 Replies

Tiny
ERNEST CLARK
  • EXPERT
Inside of your HVAC unit are vent doors along with vacuum lines and a block of vacuum solenoids.

Your issue lies with one of these components. The only way to check is to remove the unit and check. If you're interested in doing this yourself, let me know and I'll walk you through it. If you just need advise for dealing with a shop, I can help with that also.
Was this
answer
helpful?
Yes
No
Wednesday, November 17th, 2010 AT 3:05 PM
Tiny
2CEXPT
  • MEMBER
To Get to the problem you have to open the dash up-and investigate the doors-air mix/blend/mode doors, vacuum and actautors, could als be the HVAC control module
Was this
answer
helpful?
Yes
No
Wednesday, November 17th, 2010 AT 3:06 PM
Tiny
COURTROOM74@HOTMAIL.COM
  • MEMBER
This is for Ernest Clark's response - I think I have a similar problem except that the air flow **** when turn to defrog (windshild)/heat(bottom), no much air is flow through the bottom. I feel some warm air but it looks like it's "leaking" out from the compartment insteda of beng "blow" through. I would like to get a step-by-step instruction on how to solve this issue. Thanks.
Was this
answer
helpful?
Yes
No
Friday, December 31st, 2010 AT 12:19 PM

Please login or register to post a reply.

Sponsored links