I noticed my brake lights arnt working

Tiny
BRIANEMMER
  • 1995 BUICK SKYLARK

I noticed my brake lights arnt working. I have power to the run lights (they work as well as the turn signals) I checked the relay its good even swapped for good measure. Next I looked at the brake switch replaced that cuz the old one looked a lil worn inside. That didnt fix it. I dont have power on the yellow wire in the back which I figure is the brake lights because I have power to the other wires besides the ground wire. I have traced the wire to go along the door panels. Now on the brake switch I have 2 connectors one has 2 wires and the other 4 wires the 2 wire one has what seems a ground and im guessing a neutral, the 4 wire connector has all power with one switch wire power. Power goes out when pedal is pushed. Anything im missing? Can I run for test purposes a wire from the switch to the brake lights? Is this a common problem and if so where is the brake in the wire or problem ussally?

Do you
have the same problem?
Yes
No
Wednesday, March 13th, 2013 AT 1:04 AM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
  • 30,953 POSTS

Check for power at the brake light globe first and if ok check the earth feed next start here.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Wednesday, March 13th, 2013 AT 1:06 AM
Tiny
BRIANEMMER
  • MEMBER

I checked power there first I have nothing on the yellow wire if I turn on the run lights I have power at on the brown wire. I also checked the ground and it has a good ground.

Was this
answer
helpful?
Yes
No
Wednesday, March 13th, 2013 AT 1:13 AM
Tiny
BRIANEMMER
  • MEMBER

There is 5 wires coming in 2 yello 2 brown and 1 black 2 yellow dont have power at all. 2 brown have power only when running lights are on. Black wire is ground.

Was this
answer
helpful?
Yes
No
Wednesday, March 13th, 2013 AT 2:00 AM

Please login or register to post a reply.

Help us by donating