CAR IDLE VERY FAST AND DRINKING GAS AFTER TUNE UP.

1994 Subaru Legacy

Tiny

valoriedavis

February, 15, 2012 AT 3:36 AM

My car was not running badly but since I have not had a tune-up in the 5 years I have owned it I decided to have the plugs and wires changed. The plugs that were removed were gapped at 50-54 and my car manual says to gap at 39-44 so they were replaced at 40-44. I am certain all of the wires are in correct firing position. Nothing else was changed, adjusted or removed while this was being done. Now my car idles very fast and there is a burning odor after it warms up. Not running badly. Just will pull itself at 30 mph once you get it rolling and it's drinking gas (1/4 tank in 22 miles; about double the average). I don't see any vacuum lines off. I have only driven it about 80 miles since the tune-up so do I need to just give it time to adjust itself out or maybe remove the positive battery cable to reset the computer. Does it have a computer. Shade-tree mechanics. Never, ever again. Valorie Davis

FOUND 1223 RELATED QUESTIONS

Timing/tuning Problem With A

96 ANSWERS
120 IMAGES

Tuning

1 ANSWER
5 IMAGES

1 Answer

Tiny

ASEMaster6371

February, 15, 2012 AT 4:05 AM

I bet there is a vacuum leak somewhere. Take it to a real shop for a diag and find out what happened.

Roy

Please login or register to post a reply.

Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear - Dodge Stratus
Read Codes Like a Pro
Code Read Retrieval/Clear Scion XD