1994 Subaru Impreza Engine misfire

Tiny
SINGH123
  • MEMBER
  • 1994 SUBARU IMPREZA
  • 2.0L
  • 4 CYL
  • TURBO
  • 4WD
  • MANUAL
  • 100,000 MILES
1994 Subaru Impreza wrx sti jap import the car is mixed miles km and miles

I have a engine misfire and the engine is shaking?

I have changed the fuel injector, coil pack, spark plug, crank sensor, maf sensor and it's still the same

When I unplug the fuel injector clip it stays the same nothing happens as when I do the same test with the other 3 the engine goes dead and when I plug it back in the engine goes high but it doesn't happen with that one when I'm taking in or out. The car is sill performing well

Do you have a contact number
Any ideas

I will do a donation if the car is fixed
Do you
have the same problem?
Yes
No
Friday, July 24th, 2015 AT 9:19 AM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Are you getting power to the injector in question?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2015 AT 9:34 PM
Tiny
SINGH123
  • MEMBER
Hi When I unplug that injector nothing happens to the car but when I take another injector clip out then the car tries to cut out its only that one that nothing happens to it even when you unplug the coil pack nothing happens I switched the injector clip around and it still didn't make any difference to that one so I think it is getting power
Was this
answer
helpful?
Yes
No
Saturday, July 25th, 2015 AT 5:34 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi again. I need you to check that injector to confirm it is getting power. If you don't have a noid light, most parts stores will lend them. They are cheap to purchase too. Either we aren't getting spark or fuel. We need to determine which one. Check that first. If it is getting fuel, make sure you have spark to that cylinder. If you have both, check to make sure the injector isn't plugged. If it is good, then check compression in that cylinder.
Was this
answer
helpful?
Yes
No
Monday, July 27th, 2015 AT 10:01 PM
Tiny
SINGH123
  • MEMBER
When I start the car then the car has power in fuel injector and spark plug after a few mins then there is no power as nothing happens when I unplug it the engine doesn't die out stays the same so nothing is happening with either. When I start the engine for 2 mins the car is all perfect no misfire no shaking after that it starts to misfire and shake and when I unplug the coil pack and fuel injector nothing happens
Was this
answer
helpful?
Yes
No
Tuesday, July 28th, 2015 AT 1:40 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I need you to look at this link and check for codes. If you have spark and then lose it, it could be a crank or cam sensor. A code should identify it.

http://www.extreme-check-engine-light-codes.com/Subaru%20OBD1%20Decoder.htm

Let me know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, July 29th, 2015 AT 7:34 PM

Please login or register to post a reply.

Recommended Guides