STALLS THEN WONT START

1994 Pontiac Transport

Tiny

sunnstarzsm

September, 16, 2008 AT 9:42 PM

Electrical problem
1994 Pontiac Transport 6 cyl Two Wheel Drive Automatic 220000 miles

Hello,
I need desperate help fixing my handicap van!

We've spent literally 1400.00 trying to fix it. What the problem now is 2 things I think are linked. The check engine light comes on. It starts running rough and then it stalls but it either 1. Wont even turn over for about 20min or 2. It " tries" to turn over but wont start for a few hours. We have changed fuel injectors, plugs & wires, EGR valve, new engine, new trans and numerous starters. The only code is the torque convertor.

Im getting stuck everywhere and cant get a new van because of the accessibility!

FOUND 50469 RELATED QUESTIONS

6 Answers

Tiny

rasmataz

September, 16, 2008 AT 11:42 PM

1. Pull the OBD1 code/s from the computer and comeback with it.

2. Check the fuel pressure fuel pump could be failing-

Tiny

sunnstarzsm

September, 17, 2008 AT 4:26 PM

We did recently change the fuel pump & filter. Our mechanic just yesterday checked the pressure and tried to change the ignition module. It ran allll day, stayed running and would start. So we picked it up, it was running rough and by the time we got home, shut if off then tried to restart. Nothing, it just tries to start!

Tiny

rasmataz

September, 17, 2008 AT 6:56 PM

Did you pull the code/s from the computer this is the starting point without it we cannot get no where.

Tiny

kevin12881

September, 17, 2008 AT 7:12 PM

. Wont even turn over for about 20min.

Did you say new engine? Did you reatach all the old parts? Resmataz is right and you need to pull the codes, we can go on and on and on with possible problems. Does sound electrical; like your ignition system wires/connections or fuel relay. I do not know your vehicle at all and can be of little or no help. Sorry

Tiny

sunnstarzsm

September, 18, 2008 AT 9:26 PM

Yes we pulled the codes and the only code was for the torque converter, thats all and regarding the engine, We had it put in by a Pontiac dealership. It was a new crate engine. We, tonight, checked the alarm system but its still chugging and acting up : -(

Thank you everyone

Tiny

Chelsearose_1@hotmail.com

November, 19, 2011 AT 12:34 PM

I had the exact problem a couple years ago with my 3.8 Transport. We tried everything. Turned out to be the coil pack.

Please login or register to post a reply.

Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet
Fuel Pump Pressure Test
Fuel Pump Replacement Done Right
Fuel Pump Replacement