1500

1994 GMC Truck

Tiny

jhknight404

August, 11, 2011 AT 8:59 PM

I have a 1994 gmc 1500 with a 4.3L V6 it started running crappy the other day and in messing with it I have found that it only runs fine in reverse, in P, N, or and forward gears it spits and sputters and backfires and dies. Any suggestions?

FOUND 4236 RELATED QUESTIONS

Running Rough

27 ANSWERS
34 IMAGES

Idles Rough/changed Ects

37 ANSWERS
3 IMAGES

11 Answers

Tiny

rasmataz

August, 11, 2011 AT 9:31 PM
Tiny

jhknight404

August, 11, 2011 AT 9:37 PM

I understand all this but why would it run fine in reverse but not in any other gear?

Tiny

rasmataz

August, 11, 2011 AT 9:57 PM

Could be a problem with the transmission

Tiny

jhknight404

August, 12, 2011 AT 12:37 AM

I don't think its the tranny its the engine lurching and spitting except when in reverse

Tiny

jhknight404

August, 12, 2011 AT 8:33 PM

Is there some sort of sensor that might cause this issue?

Tiny

jhknight404

August, 13, 2011 AT 5:09 PM

Am I going to get any help here or what?

Tiny

rasmataz

August, 13, 2011 AT 6:23 PM

Try disconnecting the TCC solenoid and see what happens

Tiny

jhknight404

August, 13, 2011 AT 10:21 PM

Where is that located?

Tiny

jhknight404

August, 14, 2011 AT 1:01 AM

Doesn't make a difference. Someone said to try the park neutral switch. Could that make the motor run differently in different gears?

Tiny

jhknight404

August, 16, 2011 AT 2:24 PM

Where are all the gound straps on this model?

Please login or register to post a reply.

Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Mercedes Benz
How to read codes Chevrolet Blazer
Read Codes Like a Pro
Code Read Retrieval/Clear
 Step by Step video GMC Yukon XL 2000-2006
Code Read Retrieval/Clear Scion XD