1994 S-10 Blazer runs rough at idle after warmed up

Tiny
NOVACLONE
  • 1994 CHEVROLET S-10
  • 14,500 MILES

4.3 Vortec, 60,000 on engine, just changed spider injection and nut kit, spark plugs, scanned it and shows no codes, starts fine, runs good until its warmed up, runs rough at idle after warmed up, acceleratess fine, doesn't miss when rpms increased, runs fine when driving down the road, new fuel pump and fuel filter about 7,000 miles ago, have not checked egr valve, but did install a egr gasket with the screen awhile back, (maybe plugged?)Right after changing the spider injection and first starting the engine, it ran terrible, but after revving it up a fews times it ran smooth, I let it set and run for 20 minutes and revved it put in gear while sitting there and ran great fully warmed up, then drove it around the block, pulled into driveway and when I stopped, it was running rough again at idle. Couldn't find vacuum leaks, cat has never been replaced.I cleaned the idle air valve, and nothing

Do you
have the same problem?
Yes
No
Monday, September 17th, 2012 AT 3:42 PM

5 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,974 POSTS

Did you clean the throttle body?
Seems problem is low idling speed and it can be due to air flow restriction along idle air control circuit.

Was this
answer
helpful?
Yes
No
Monday, September 17th, 2012 AT 4:12 PM
Tiny
NOVACLONE
  • MEMBER

Yes I cleaned everything when I had the top part of the intake off to install the spider unit, maybe bad idle air flow valve?How do you check them?

Was this
answer
helpful?
Yes
No
Monday, September 17th, 2012 AT 4:22 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

Did you look to see if there is any carbon on the egr pindle. Even if you have a screen, it can still prevent the pindle from seating and causing a rough idle.

Roy

Was this
answer
helpful?
Yes
No
Tuesday, September 18th, 2012 AT 1:55 AM
Tiny
NOVACLONE
  • MEMBER

After driving it for a couple of days, I was just getting ready to check egr valve, and now all of a sudden it is idling and running fine, hate these kinds of things.

Was this
answer
helpful?
Yes
No
Wednesday, September 19th, 2012 AT 5:36 AM
Tiny
KHLOW2008
  • EXPERT
  • 41,974 POSTS

Guess you don't have the problem. The computer has just relearnt your preferences.

Was this
answer
helpful?
Yes
No
Wednesday, September 19th, 2012 AT 9:02 AM

Please login or register to post a reply.

Other Engine Runs Rough Questions