1993 Saturn SL1 Bad Rocker Arms or Compression?

Tiny
JOHN6980
  • MEMBER
  • 1993 SATURN SL1
  • AUTOMATIC
Used to just low tone click but recently gotten worse. Starts fine but when I start to back up slow it will start clicking under the hood. When done backing up out of driveway stops. At a stop sign or stop light on idle it will most of the time start clicking again but this time it will miss and the engine will shake. Has not stalled but I guess it could I don't know. When I start to move again stops. No other times it does it. Tune up is fairly new and coils and module is new. Belt is new and tenisoner is fine. Sounds like clicking is near the belt but it's possible it can echo there. Exhaust is fine.

I have someone telling me it's the compression and someone else tells me rocker arms or cam lifts. I search to get a price on rocker arms to see if worth to fix if they are bad but I don't see any, does this car even have rocker arms?

Prefer if saturntech to answer if available. Thanks.
Do you
have the same problem?
Yes
No
Thursday, July 2nd, 2015 AT 10:06 PM

3 Replies

Tiny
SATURNTECH9
  • EXPERT
Yes it has rockers and roller lifters as far as shaking at idle is it actually missing or is the engine just vibrating like a bad engine mount?As far as the rockers clicking I kind of doubt that most of the time that would be the lifters. The clicking could also be a loose timing chain you could remove the valve cover and check the timing chain for looseness etc.
Was this
answer
helpful?
Yes
No
Saturday, July 4th, 2015 AT 7:57 AM
Tiny
JOHN6980
  • MEMBER
Sorry for late reply. I'd appreciate a answer if you are available. Thanks.

Engine mounts are new. It's shake not vibrate when I can feel it. Not constant it may do a little at idle quit do a little more, quit when I start moving faster than a 1-5 mph. My feeling is it could possible stall but has not yet. On a very rare occassion it will click when driving on the rd but I never feel the shake at that time. All of the fluids are fine I just checked yesterday and are all fairly fresh.

I think it feels like when the egr valve was bad but that's new except that was constant. Clicking starting several months after.
Was this
answer
helpful?
Yes
No
Saturday, July 18th, 2015 AT 9:00 AM
Tiny
SATURNTECH9
  • EXPERT
What kind of spark plugs did you put in?Also you changed the coils and module but not the spark plug wires?When you changed the coils were the coil towers corroded with white powder on them?
Was this
answer
helpful?
Yes
No
Monday, July 20th, 2015 AT 6:21 AM

Please login or register to post a reply.

Recommended Guides