MY CAR GOES VERY SLOWLY FORWARD

1993 Mitsubishi Montero

Tiny

chemmi

October, 31, 2012 AT 7:57 PM

My car goes very slowly forward. I put in engine and transmission oil in it and thats when it started going very slow forwards. What do you think the problem is?

4 Answers

Tiny

KHLow2008

October, 31, 2012 AT 8:00 PM

Where did you put in engine oil and transmisison fluids? Did you check the transmission fluid level? Was engine oil overfilled?

Tiny

chemmi

October, 31, 2012 AT 8:06 PM

My husband put the oils in, he said that he put two things of oil in the transmission and one in the engine. I told him that I had just put engine oil a few days before that and he act like it didnt matter.

Tiny

chemmi

October, 31, 2012 AT 8:08 PM

Do you think that could have caused the problem? I dont know if he even checked the engine oil. We had been having trouble with our transmission oil leaking for awhile. And constantly putting oil in that. But the engine oil was ok.

Tiny

KHLow2008

October, 31, 2012 AT 8:17 PM

If you had engine oil in transmission or vice versa, that could spell trouble. If transmission fluid is leaking, the fluid level could be low causing the lack of power but then under such circumstances, the engine would race (sounds loud with tachometer shooting up) and you have lack of accelerating pace.

If the engine oil is overfilled too much, it would result in loss of power and you might get a lot of smoke from the exhaust.

If the Malfunction Indicator Light is showing, you need to retrieve the trouble codes and let us know the EXACT code, it might tell us what is wrong.

Was problem there before oil and fluid replacement?

Please login or register to post a reply.

Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear - Dodge Stratus
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear Chevrolet Camaro
How to gather codes Ford Explorer
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Mercedes-Benz C230