ENGINE SHAKING LIKE IT HAS A VACUM LEAK?

  • Tiny
  • Starsky_33
  • 1993 MITSUBISHI EXPO
  • 113,715 MILES

I check spark plug look bad so I change them but it still shake when driving it feel like there a leak somewhere are something? Please help

Do you
have the same problem?
Yes
No
Tuesday, October 11th, 2011 AT 5:20 AM

6 Replies

  • Tiny
  • Rivermikerat
  • MEMBER

It sounds like maybe a vacuum leak, timing issue, or crossed plug wires.

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 5:23 AM
  • Tiny
  • Rivermikerat
  • MEMBER

I use a can of carburetor and choke cleaner to check for vacuum leaks normally.

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 5:26 AM
  • Tiny
  • Starsky_33
  • MEMBER

Check them there are all good? Could the fuel filter are 02 do this

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 5:35 AM
  • Tiny
  • Starsky_33
  • MEMBER

Try it and look at it there all good ! Could the 02 are fuel filter do it are cause it

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 5:38 AM
  • Tiny
  • Starsky_33
  • MEMBER

I do have one question? Could the spark plug wire be bad even if it look new?

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 5:42 AM
  • Tiny
  • Rivermikerat
  • MEMBER

Yes it can. The O2 sensor can, if malfunctioning badly enough, it can cause the computer to hold the injectors open longer than necessary, causing an extremely rich condition which can cause a rough idle.

Check to see if it's throwing any codes, whether hard or soft.

Was this
answer
helpful?
Yes
No
Tuesday, October 11th, 2011 AT 7:13 AM

Please login or register to post a reply.

Other Engine Shake Questions