Car Trouble

Tiny
EBONNER
  • 1993 MITSUBISHI EXPO
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 150,000 MILES

I have a 1993 Mitsubish Expo (Eagle Summit) that just cut out on me. It gets spark and Gas but will not start can you help he figure out the problem?

Do you
have the same problem?
Yes
No
Tuesday, July 12th, 2011 AT 4:07 PM

6 Replies

Tiny
KHLOW2008
  • EXPERT
  • 41,975 POSTS

Are the sparks strong?
Have you checked the compression?

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 4:14 PM
Tiny
EBONNER
  • MEMBER

Yes; it gets spark and gas but it wont start.

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 4:21 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,975 POSTS

Weak sparks might not start the engine.

Have you checked the compression?
Was aanything doene prior to this occurring?

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 4:46 PM
Tiny
EBONNER
  • MEMBER

I had a rear control arm done. When that was finished I drove it to the store when I got a block from my house at a stop light it did a quick shake and just cut out. We thought it was the timing belt but that was fine then we checked the spraks and gas that was fine too. I will have them check the sparks again and compression again. Thanks For you help if you can think of anything else please let me know

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 4:52 PM
Tiny
KHLOW2008
  • EXPERT
  • 41,975 POSTS

Are the injectors firing?
Put some starting fluids in the throttle body to check if it fires up briefly.

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 5:07 PM
Tiny
EBONNER
  • MEMBER

Ok I will try that thanks for all your help

Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 5:14 PM

Please login or register to post a reply.

Other Engine No Start Questions