LOST OF POWER,ROUGH IDLE & WHEN GIVING IT GAS RPM'S DROP

1993 Lexus GS 300

Tiny

terrell brandon

September, 19, 2011 AT 10:46 PM

I was diving one day doing 60mph and all of sudden I could not accelerate and lost power coming from emission test that I passed. Ive just had a full tune up change mass air sensor no change, still no power and rough idle.

FOUND 16219 RELATED QUESTIONS

7 Answers

Tiny

Jacobandnickolas

September, 20, 2011 AT 12:32 AM

Check catalytic converter for plugging, check for vacuum leaks, check fuel pump pressure.

Tiny

terrell brandon

September, 20, 2011 AT 1:02 AM

When I unplug the mass air flow sensor it idle & run the mass air flow is new out the box the second one I took the first one back because their was no change

Tiny

ronsellers

September, 23, 2011 AT 6:25 PM

It is your ECU Module. Probably got hit by severe heat. Typically it is the capacitors that need replacement on the board (less than $2) but you need a TV repair place to solder the new caps on board. $20 generally. The problem is finding where it is. This was ask before but was not answered. Instead they said check the battery cables. Lol

Tiny

ronsellers

September, 23, 2011 AT 6:26 PM

Do this work?

Tiny

ronsellers

September, 23, 2011 AT 6:29 PM

You could not accelerate because to ECU dropped you into Limp mode. You will need to downshift to run the car.

Tiny

terrell brandon

September, 23, 2011 AT 6:57 PM

I will try that what do it look like & where is it located

Tiny

terrell brandon

October, 1, 2011 AT 6:34 PM

Once agian same problem; now changed the ecu, full tune, checked the cats new vac hoses new mass air flow sensor and also change the complet throttle body & cleaned it car still wont idle rpms are low

Please login or register to post a reply.

Catalytic Converter Replacement Volkswagen
Find Out How to Test Your Catalytic Converter
Fuel Filters Replacement 2015 RAM 2500 6.7L
Fuel Pump Test Chevy Tahoe
Fuel Filter Replacement Toyota Tacoma