Rolling a squeaky kind of spinning sound

Tiny
JOJORISIN
  • MEMBER
  • 1993 GEO STORM
  • 4 CYL
  • 2WD
  • MANUAL
  • 160,000 MILES
93 geo storm. When its rolling there's a squeaky kind of spinning sounding noise, left side from the wheel to under the hood. Is ti my speedo or odom cable(s). Sounds like a spinning thing

I can't see anything looking under by the left wheel. Nothings loose at wheel. But after I'm driving it gets noisier. Like a squeak, squeak, squeak, squeak, squeak, squeak, squeak
Do you
have the same problem?
Yes
No
Tuesday, January 31st, 2012 AT 8:43 AM

5 Replies

Tiny
RIVERMIKERAT
  • EXPERT
It could be a lower control arm bushing or a hub bearing drying out.
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2012 AT 8:56 AM
Tiny
JOJORISIN
  • MEMBER
Thank you, that will be the first thing I check. JoJoRisin
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2012 AT 9:25 AM
Tiny
RIVERMIKERAT
  • EXPERT
Let me know what you discover. Look for cracks in the bushings. Use a screwdriver or prybar to check for excess play.
Was this
answer
helpful?
Yes
No
Tuesday, January 31st, 2012 AT 9:44 AM
Tiny
JOJORISIN
  • MEMBER
I'm taking it to my buddy's place 2morrow. Suspend the front wheels , put it in gear and listen to my poor car cry. You Don't think it could be the speed. Or odometer cables, maybe one or both are all unwound or loose on the inside. The gauges work. Thanks so much for yer time.
Was this
answer
helpful?
Yes
No
Wednesday, February 1st, 2012 AT 4:42 AM
Tiny
RIVERMIKERAT
  • EXPERT
Speedometer and odometer work off an electronic sensor, the vehicle speed sensor. It's electronic.
Was this
answer
helpful?
Yes
No
Wednesday, February 1st, 2012 AT 5:28 AM

Please login or register to post a reply.

Recommended Guides