Trucks been mesed up for long time

Tiny
JUDOJOE
  • MEMBER
  • 1993 FORD EXPLORER
  • 2 MILES
OK so I bought a 1993 ford explore with a v6 4.0, when I got it we found out one problem was the fuel pump had a huge hole in the feeding tube. Fixed that but it was still not getting over 3 rpms and stalling out, and jumping to higher rpms and jumping back down all at the same time my foot was to the floor and I was steady losing speed. So then I replaced the mas Flo, idle air motor, and the other one there that regulates the throttle. Also I change the fuel filter and it has half a tune up but still problems. Till I got a code reader ran on it then all my problem magically disapered till now there back and I have no clue what is wrong. I am also getting a strange gurgling from the fuel tank when my fuel pump turns on? I need help. Oh code reader only said it was getting improper throttle response but no reason why.
Do you
have the same problem?
Yes
No
Saturday, May 26th, 2012 AT 11:37 PM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
Forget the code reader. Obd 1 was very general failures.

You should have replace the fuel pump. It sounds like your pressure is too low. Did you check the actual pressure with a gauge?

Roy
Was this
answer
helpful?
Yes
No
Saturday, May 26th, 2012 AT 11:42 PM
Tiny
JUDOJOE
  • MEMBER
I did replace the fuel pump its brand new and I do not know how to check the fuel pressure nor do I have a gauge for it and whats the right pressure
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2012 AT 1:39 AM
Tiny
JUDOJOE
  • MEMBER
Oh wher can I get a gauge
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2012 AT 1:39 AM
Tiny
ASEMASTER6371
  • EXPERT
40-45 lbs. You can rent one at a parts store.

Did you replace the whole unit or just the pump?

Roy
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2012 AT 2:26 AM
Tiny
JUDOJOE
  • MEMBER
The hole thing fuel pump and sending unit
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2012 AT 2:29 PM

Please login or register to post a reply.

Sponsored links