TRANSMISSION

1993 Ford Explorer

Tiny

jakehendricks

September, 20, 2013 AT 10:48 PM

I took my transmission out to change my front seal. When I removed it I left my torque converter attached to the motor. I got the transmission out changed the seal filter an gasket. Re installed it it went in fine hooked it all back up like it was before. Now it wouldn't go in gear. So I took it back out with torque converter in the transmission this time. Then I removed the torque converter filled it with fluid put it in turned to till it popped in then re installed it. An still won't go in gear. It went in gear fine till I took it out to replace the seal an filter an gasket.

FOUND 579 RELATED QUESTIONS

4 Answers

Tiny

mhpautos

September, 20, 2013 AT 11:53 PM

You may have damaged the pump drive when you tried to refit the trans the first time, this is easily done if the converter is not fitted correctly.

Tiny

jakehendricks

September, 21, 2013 AT 11:22 AM

How should I go about fixing that do I need a hole new transmission or a new pump?

Tiny

jakehendricks

September, 21, 2013 AT 11:44 AM

I been asking everyone I know and they can't tell me anything its been tore up for weeks now I just need to know what I should do about it

Tiny

mhpautos

September, 21, 2013 AT 5:03 PM

Take the transmission to a trans work shop, get the pump checked and repaired if required, and get them to re fit the torque converter so it is positioned correctly.

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Chevrolet Camaro
Transmission Service Ford Super Duty F-250