IS MY MAF SENSOR BAD

1993 Ford Explorer

Tiny

ajkilpatrick

August, 9, 2012 AT 1:29 AM

I have a 1993 ford explorer. I thought the MAF sensor was bad so I replaced it. This did not fix the problem. When I hit the gas pedal the vehicle does not respond and then dies. It also revs up irratically then dies. I need help, please.

FOUND 692 RELATED QUESTIONS

6 Answers

Tiny

saturntech9

August, 9, 2012 AT 1:50 AM

Any codes?Have you checked the fuel pressure?

Tiny

ajkilpatrick

August, 9, 2012 AT 2:16 AM

Yes code 185. Fuel pressure is good. Also when I put a ground to the maf signal wire the truck starts idling normally?

Tiny

ajkilpatrick

August, 10, 2012 AT 1:26 AM

Sorry code 157

Tiny

carolinacarconnection

August, 11, 2012 AT 12:59 AM

Well it sounds to me like you got a defective maf or your connector is bad. Check the connector really good make sure its making good contact. If it is take the maf back to the parts store and tell them its defective and get another one.

Tiny

carolinacarconnection

August, 11, 2012 AT 1:00 AM

Code number 157 is a maf signal code by the way.

Tiny

ajkilpatrick

August, 13, 2012 AT 8:09 PM

Got another one, it did not work either. Connectors are fine. I also checked the wire #14 at the pcm, should I change my pcm? Do you think that may fix it?

Please login or register to post a reply.

Mass Air Flow Sensor Clean Toyota Tacoma
Mass Air Flow Sensor Clean Ford Explorer 1995
Code Read Retrieval/Clear
How to read codes Chevrolet Blazer
How to gather codes Ford Explorer
Code Read Retrieval/Clear Honda Civic