Car has no spark when trying to start what could be the problem?

Tiny
TASSIETRACEY
  • 1992 MITSUBISHI MAGNA
  • 208,200 MILES

When trying to the car it has no spark, we have tried replacing the coil, distributor, ecu, the is fuel getting through the fuel pump. Any ideas would be great. Someone said it might be the engine fuse but can not find one anywhere.

Do you
have the same problem?
Yes
No
Tuesday, December 6th, 2011 AT 8:51 PM

10 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,342 POSTS

Check crank sensor.

Was this
answer
helpful?
Yes
No
Tuesday, December 6th, 2011 AT 9:18 PM
Tiny
TASSIETRACEY
  • MEMBER

Where do I find that?

Was this
answer
helpful?
Yes
No
Tuesday, December 6th, 2011 AT 9:35 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,342 POSTS

It should be on the front of the engine near harmonic balancer.

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Tuesday, December 6th, 2011 AT 10:18 PM
Tiny
TASSIETRACEY
  • MEMBER

I have been told that my magna doesn't have a crank sensor. So do you know what else it could be really need help to get car on the road again

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 12:26 PM
Tiny
RASMATAZ
  • MEMBER

What liter engine is this?

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 12:38 PM
Tiny
TASSIETRACEY
  • MEMBER

It has a 2.6 litre and its a 4cyl.

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 12:50 PM
Tiny
TASSIETRACEY
  • MEMBER

2.6 ltr and its 4cyl

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 12:52 PM
Tiny
RASMATAZ
  • MEMBER

The crank angle sensor is in the distributor-

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 2:00 PM
Tiny
TASSIETRACEY
  • MEMBER

Ok well it has a brand new distributor in it. So I cant really see it being that. What else could it possibly be?

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 7:44 PM
Tiny
RASMATAZ
  • MEMBER

Never know manufacturer defects

Was this
answer
helpful?
Yes
No
Wednesday, December 7th, 2011 AT 11:07 PM

Please login or register to post a reply.

Related Engine No Start Questions

Recommended articles