MY CAR IN DRIVE BUT WONT GO ANYWHERE?

  • Tiny
  • Keller531
  • 1992 CADILLAC DEVILLE
  • 71,000 MILES

On my cadillac the transmission oil cooler hoses or lines had a pin hole in them from rubbing upon trying to patch because the parts to replace was on backorder when drove the car all the fluid leaked out and it started coasting could'nt go anywhere. Replaced the fluid and it made it not to far and the fluid leaked out again is my transmission fried or with any luck after getting the new hoses will it hopefully work?

Do you
have the same problem?
Yes
No
Friday, March 9th, 2012 AT 12:39 AM

3 Replies

  • Tiny
  • DrCranknWrench
  • EXPERT
  • 3,456 POSTS

It is possible it is okay. It is hard to say. One thing that happens that keeps clutches from grabbing is the pump pressure fails to build if there is not enoguh fluid or if the ine is a pressure line.
You will have to replace the hose and see. Make sure you check the fluid level with the car running and after you have warned it up and put it into each gear once or twice. Then check level. If car works, keep an eye on condition of fluid. If it begins to get dark or smells burnt, take it to a transmission shop. Do it ASAP as it may be something that can be at least patched.

Was this
answer
helpful?
Yes
No
Friday, March 9th, 2012 AT 1:15 AM
  • Tiny
  • Keller531
  • MEMBER

Thank you I will try this and see.

Was this
answer
helpful?
Yes
No
Friday, March 9th, 2012 AT 1:24 AM
  • Tiny
  • DrCranknWrench
  • EXPERT
  • 3,456 POSTS

Your very welcome. Let me know how it turns out.

Was this
answer
helpful?
Yes
No
Friday, March 9th, 2012 AT 6:43 AM

Please login or register to post a reply.

Other Oil Cooler Hose Questions