I JUST REPLACED MY FRONT STRUTS AND MOUNTS A FEW...

1991 Nissan 240SX

Tiny

russribelin

March, 26, 2013 AT 11:43 PM

I just replaced my front struts and mounts a few weekends ago and now I'm getting an intermittent squeak when I turn left. It doesn't happen all the time, and when it does it's usually at low speeds. I put the struts together myself and only reused the bottom bolts, everything else is new (strut mount, mount gasket, spring seat, bushing, bump stop, etc)

FOUND 530 RELATED QUESTIONS

5 Answers

Tiny

ASEMaster6371

March, 26, 2013 AT 11:49 PM

Could be a tie rod end, ball joint or possible axle.

Any idea where the noise is coming from?

Roy

Tiny

russribelin

March, 27, 2013 AT 12:00 AM

Definitely from the front left side. When I was under the car putting on the struts, I did notice the rubber of the tie-rod ends and ball joints were cracked and dry. When I took my car in to get an alignment done, they said they couldn't do it because the tie-rods were worn out.

Tiny

ASEMaster6371

March, 27, 2013 AT 12:02 AM

Replace them with ones with grease fittings. I would start there.

Roy

Tiny

russribelin

March, 27, 2013 AT 12:05 AM

Awesome, that was actually the next project on my list. It'll be a couple weeks (gotta save up the cash), will it hurt anything if I ride around with it as is?

Tiny

ASEMaster6371

March, 27, 2013 AT 12:06 AM

Be carefull if they are worn out. You dont want them to brake

Roy

Please login or register to post a reply.

Replacing Your Front Struts Like a Pro
Safely Replace Your Rear Struts
Air Shock Replacement Mercedes Benz S Class
Shock Replacement - Front Chevrolet Silverado
Lower Control Arm Bushing Replacement Honda
Upper Control Arm Replacement