Why is truck is stalling with the A/C or the defrost on

Tiny
SHAWNRPRICE
  • MEMBER
  • 1991 FORD F-150
  • 150,000 MILES
My truck has a 5.0 with a 5 speed transmission. When turn on the defrost or the A/C the truck stalls. I thought it was the Idle air control valve so I replaced it. Still stalling. Next I thought maybe the throttle position sensorwas bad. I replaced it, still stalling. I have a code scanner and have retrived codes from the computer and there are no trouble codes. At this point I am at a loss as to what the problem is and am contemplating taking it to Ford to see what they feel is wrong. Would you happen to know what the problem might be?

Thank you.

Shawn
Do you
have the same problem?
Yes
No
Friday, March 23rd, 2012 AT 11:06 PM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
With the engine shut off see if the center of the ac clutch turns freely you may have a locked up ac compressor.
Was this
answer
helpful?
Yes
No
Friday, March 23rd, 2012 AT 11:17 PM
Tiny
SHAWNRPRICE
  • MEMBER
I'm sorry I didn't mention this before. While checking things I thought the A/C compressor might be the problem so I removed the serpentine belt, connected jumpers wires to the compressor to engage the clutch and was able to spin the A/C compressor by hand fairly easy. I have also tried to disconnect the battery and reconnect to see if the computer had a glitch that might be able to erased. This is a real head scratcher for me.
Was this
answer
helpful?
Yes
No
Friday, March 23rd, 2012 AT 11:22 PM
Tiny
SATURNTECH9
  • EXPERT
Have you had the battery and alternator tested yet?Also made sure the battery cables are clean and tight?
Was this
answer
helpful?
Yes
No
Saturday, March 24th, 2012 AT 12:51 AM
Tiny
DJCL
  • EXPERT
Will it stall when cutting the wheel hard to one side?
Was this
answer
helpful?
Yes
No
Saturday, March 24th, 2012 AT 1:07 AM
Tiny
SHAWNRPRICE
  • MEMBER
No, I have turned the steering wheel both left and right and it has not stalled
Was this
answer
helpful?
Yes
No
Saturday, March 24th, 2012 AT 1:22 AM
Tiny
SHAWNRPRICE
  • MEMBER
I have not had the battery and alternator tested. My battery was replaced in May 09 (I replace them every 5 years even if they still act good) and my alternator was replaced in Feb 11. After you response I did go check my battery connections. They were not the cleanest so I thoroughly cleaned them and made sure they were good and tight. After that I started the truck and it didn't stall while idling like it did before. I will test drive it tomorrow morning to see if my truck is cured. I will let you know the outcome. Thank you for your help with this.
Was this
answer
helpful?
Yes
No
Saturday, March 24th, 2012 AT 1:26 AM
Tiny
SATURNTECH9
  • EXPERT
Your welcome please keep me updated.
Was this
answer
helpful?
Yes
No
Saturday, March 24th, 2012 AT 2:14 AM
Tiny
JOHNSGARAGE99
  • MEMBER
Alot of the 5.0 v-8 fords had a cutout switch for the a/c. The switch mounts on the power steering hose. If a p/s hose has been replaced some of the universal hoses do not come with the switch port. This cuts out the a/c compressor when p/s pressure is high.
Was this
answer
helpful?
Yes
No
Sunday, March 25th, 2012 AT 2:51 AM

Please login or register to post a reply.

Recommended Guides