1991 Cadillac Fleetwood blower motor control module/resistor replacement

Tiny
FULLKEG
  • 1991 CADILLAC FLEETWOOD
  • V8
  • 2WD
  • AUTOMATIC
  • 44,400 MILES

I am trying to replace my blower motor control module/resistor in a '91 Cadillac Fleetwood. My problem is that the new part I ordered (GM part # 12484912) does not physically match the part I removed (GM part # 16061602). I understand the original is no longer manufactured, and the one I received is the replacement, but the mountings just do not match. Does anyone have any idea how to get the new part into the old hole?

Do you
have the same problem?
Yes
No
Wednesday, June 8th, 2011 AT 8:56 PM

13 Replies

Tiny
FACTORYJACK
  • EXPERT
  • 4,233 POSTS

It is the mounting of the unit, and not the electrical connections? I will check on the number and reply to post, but first I need to know if this is truly a rear wheel drive, or is it a front wheel drive fleetwood?

Was this
answer
helpful?
Yes
No
Wednesday, June 8th, 2011 AT 9:43 PM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

They are a tight fit into the hole with the cooling fins in the way but they will usually go after a little manipulating.

Was this
answer
helpful?
Yes
No
Wednesday, June 8th, 2011 AT 9:56 PM
Tiny
FULLKEG
  • MEMBER

It is the mounting that is not the same. The new part is a bit smaller and a little different shape than the old part. The electrical connections are the same on both. I will try to attach pictures of both parts and maybe you can see what my problem is. And thanks for getting back with me so soon.

Was this
answer
helpful?
Yes
No
Wednesday, June 8th, 2011 AT 10:08 PM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

The screw holes should still line up.

Was this
answer
helpful?
Yes
No
Wednesday, June 8th, 2011 AT 10:46 PM
Tiny
FULLKEG
  • MEMBER

That's the big problem Wrenchtec, the screw holes aren't even close. The old one had 2 mounting screws/holes and the new part has 3. Also, the parts are a different size. The new one is a bit smaller than the old one and the shape is also a bit different. I'm bumfuzzled.

Was this
answer
helpful?
Yes
No
Wednesday, June 8th, 2011 AT 11:59 PM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

Then you just have the wrong part.

Was this
answer
helpful?
Yes
No
Thursday, June 9th, 2011 AT 12:00 AM
Tiny
FULLKEG
  • MEMBER

That's what I was thinking, but I've searched for the proper part literally dozens of times online, on different sites, and the one pictured still comes up as the replacement part. Thanks for your feedback.

Was this
answer
helpful?
Yes
No
Thursday, June 9th, 2011 AT 12:04 AM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

I think I see your problem. The modules are different from the RWD Fleetwood Brougham and the FWD Fleetwood.

The pic on the left is the RWD and the one on the right is the FWD

Was this
answer
helpful?
Yes
No
Thursday, June 9th, 2011 AT 12:09 AM
Tiny
FACTORYJACK
  • EXPERT
  • 4,233 POSTS

I am showing 12484912 to be for a front wheel drive fleetwood, and 12368386 to be for a rear wheel drive fleetwood brougham.

Was this
answer
helpful?
Yes
No
+2
Thursday, June 9th, 2011 AT 12:17 AM
Tiny
SATURNTECH9
  • EXPERT
  • 31,153 POSTS

So is the one that looks like yours the picture on the right you posted?

Was this
answer
helpful?
Yes
No
Thursday, June 9th, 2011 AT 12:35 AM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

It looks like they gave you the one for the FWD instead.

Was this
answer
helpful?
Yes
No
+1
Thursday, June 9th, 2011 AT 12:44 AM
Tiny
FULLKEG
  • MEMBER

Thanks so much guys! Yep, that was the problem. I'm not really sure why I kept getting the FWD part number, but now my searches are bringing up the correct part. Wrenchtec, you're my new hero. And gstacey, thanks for the part number.

Was this
answer
helpful?
Yes
No
Thursday, June 9th, 2011 AT 1:17 AM
Tiny
WRENCHTECH
  • EXPERT
  • 20,913 POSTS

Closing question

Was this
answer
helpful?
Yes
No
Thursday, June 30th, 2011 AT 11:35 PM

Please login or register to post a reply.

Recommended Guides