Why my 1991 caddilac, Brougham, 305 V8 will not start?

Tiny
WILLIE BAILEY
  • MEMBER
  • 1991 CADILLAC BROUGHAM
  • V8
  • 2WD
  • AUTOMATIC
  • 113,000 MILES
While troubleshooting my car, I found the wires to the speed sensor and TCC solenoid all five wires were bare were touching. Maybe that is why the speedometer only shows zero when the car is driven

I cut out the bare wires and spliced them. When I tried to start the car, it turns over but will not start. I got a check engine light. When I installed a jumper wire between terminals a and b on the diagnosticv terminal, I got code 54. This code on page 6-15 in my Haynes repair manual, reads, the mixture control solenoid voltage is high at the ECM because of a shorted M/C solenoid circuit/ or faulty ECM. My car is fuel injected and does not have a mixture control solenoid. That part is on a carburated engine.

I ordered a new ECM. Before I change it, I would appreciate input on my problem. I have checked all of the wiring to the ECM, battery, starter, TPITCC solenoid, speed sensor and speed sensor buffer. All of the fuses are good.
Do you
have the same problem?
Yes
No
Saturday, February 4th, 2012 AT 11:04 PM

7 Replies

Tiny
RASMATAZ
  • MEMBER
If its cranking over and will not start -Go to this link:http://www.2carpros.com/articles/car-cranks-but-wont-start
Was this
answer
helpful?
Yes
No
Saturday, February 4th, 2012 AT 11:09 PM
Tiny
CADIEMAN
  • MEMBER
Are you sure your reading this code right?You blew something do all the fuses under the hood and inside good?Youll need to check with a test light. Do you have the proper year manual. Check the fuses in the r/s under dash relay panel.
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 12:18 AM
Tiny
CADIEMAN
  • MEMBER
Check the fuses under the hood, under the r/side of the dash in the relay panel and the interior fuse panel. Use a test light and make sure they all show voltage on both sides.
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 4:19 AM
Tiny
WILLIE BAILEY
  • MEMBER
My 1991 caddilac RWD brougham, 305 v8, does not have a relay/fuse panel under dash RH access panel. Nor does it have a fuse panel under the hood. There ar three fuses on the RH fender well in line in wires coming from the positive stud in a red plastic small box for positive wires and a cable coming from the positive battery cable.

There is a small fuse panel outbd of the main fuse panel, under dash LH side. It has five fuses in locations marked 1.4, 5.6 and 7. There are six grey 30/20 amp, 12v plastic square fuses and one black one. All of the blade fuses checked good. I have not checked the grey and black ones. I do not know how to check the pastic ones.

I am checking the check engine light with the car diagnostic terminal. After I get the 12 code, I get five blinks, pause and then four, I checked it several times. The reason I suspect the ECM, is because that code indicates it could be bad. My car also has speedometer indication problems. Everything works as advertised on the instrument cluster, except the MPH indication when driving the car.
Was this
answer
helpful?
Yes
No
Sunday, February 5th, 2012 AT 9:11 PM
Tiny
CADIEMAN
  • MEMBER
Been a long time since ive been at the dealer.I researched a correct answer.I know 12 is system clear. Now a code 54 is egr sys. Failure or fuel pump circut low voltage. Since it wont start we need to check the fuel pump circut.I remember all those broughams having fuse and relay panel mounted below the glove box right under the lower dash panel on the r/side of the dashs it maybe mounted to the firewall r/side to and this was where the 20 amp. Fuel pump fuse is. Please check again. We can start here and then we can fix the speed sensor problem next. Before you do anything go to red box that the possitive cable goes to open it you will see small fuse link wires going into the car. Pull on them 1 by 1 and make sure 1 isnt blown.
Was this
answer
helpful?
Yes
No
+1
Monday, February 6th, 2012 AT 3:57 AM
Tiny
WILLIE BAILEY
  • MEMBER
Sir, I have checked the fuses and pulled the small wires to the fuses, coming out of the red box, they are ok. I checked all of the wires and fuseable links coming out of the red box, everything is good. There are no fuses or relays under the das rh side. Again my car has a small fuse panel with five fuses and six grey 30/20 amp, 12 volt relays next to the main fuse panel, lh side. All of my fuses are good. Can you provide me a diagram that labels the five fuses and relays? I can not find one. I will receive the new ECM Friday. I will install the PROM and try to start the car. Mean while I will check the fuel pump for pressure. I did remove the fuel line at the TPI and there was fuel present. The car cranked fine until I repaired the naked wires to the TCC solenoid and speed sensor on the transmission.
Was this
answer
helpful?
Yes
No
Monday, February 6th, 2012 AT 2:13 PM
Tiny
CADIEMAN
  • MEMBER
Nothing points to the ecm here.U can rent a fuel pressure gauge at the parts store. Check it and also try spray and see if it cranks.
Was this
answer
helpful?
Yes
No
+2
Monday, February 6th, 2012 AT 11:00 PM

Please login or register to post a reply.

Related Engine Not Starting Content

Recommended Guides