WINDSHIELD WIPER MOTOR TURNS ON AS SOON AS I START CAR

1991 Buick Century

Tiny

Winks

January, 23, 2012 AT 5:53 PM

Windshield wiper motor turns on as soon as I start car. Also, the blades wont move.

FOUND 630 RELATED QUESTIONS

3 Answers

Tiny

saturntech9

January, 23, 2012 AT 6:21 PM

So you can hear the motor running as soon you start the car without turning the wipers on?Also the wipers dont move with the motor on?Have you checked to see if the wiper arm nuts are loose?You could have a bad logic board keeping the wiper motor running. Do you have a multimeter to do some testing?

Tiny

Winks

January, 23, 2012 AT 7:00 PM

Happened today on way to work, have not taken anything apart yet. Wiper arm nuts? The arms themselves are firmly seated, I can move one (a little) and the other will move - linkage ok I assume. Wipers were turned on in heavy snow. The spline(?) Gears may be stripped, but the motor coming & staying on? I do have a multimeter.

Tiny

saturntech9

January, 23, 2012 AT 7:52 PM

Arms shouldnt move without the motor I would check those nuts that hold the arms on the splined shaft. If there tight then you have a spline issue on the arms or shaft or a broken linkage. Also do you have the two speed wiper or does it have the intermintant wiper function?

Please login or register to post a reply.

Wiper Blade Replacement Acura MDX
Windshield Wiper Blade Replacement Mercedes
Wiper Blade Replacement GMC Yukon
Windshield Wiper Replacement Kia Sportage
Windshield Wiper Replacement Ford Explorer
Windshield Wiper Replacement Ford Escape
Windshield Wiper Replacement
Wiper Blade Replacement Porsche Carrera