NEED HELP

1990 Oldsmobile Calais

Tiny

bigjay33

September, 12, 2012 AT 6:33 PM

I have a 1990 Olds Calais that I am trying to make a custom show car. Idles fine when in park but idle really rough when put in reverse or drive until you accelerate. I checked for vac leaks and cant seem to find one though that is how its acting. Replaced egr valve, o2 sensor, manifold air temp sensor, map sensor, collant temp sensor, spark plugs and wires. No check engine light. One mechanic of the many said he put it on computer and nothing came up. I also replaced radiator and hoses and it has a brand new battery. Not sure what else to do need help!

FOUND 656 RELATED QUESTIONS

4 Answers

Tiny

ASEMaster6371

September, 12, 2012 AT 7:15 PM

What about motor mounts?

Roy

Tiny

bigjay33

September, 13, 2012 AT 7:56 AM

I do have a mount that needs replacing but the engine is def bogging down. Went to see a mechanic a friend knows and he thinks my engine bearings may be going out and its creating low oil pressure. I asked how I tell if its the pump or the bearings and they said it would cost $200 to run tests to check. But im not getting a low oil pressure light. He said thats why he thinks its the bearings. Suggested lucas oil treatment to possibly increase internal oil pressure.

Tiny

ASEMaster6371

September, 13, 2012 AT 11:27 AM

Will do nothing for your issue. Do not go there.

Start with a fuel pressure test

Roy

Tiny

bigjay33

September, 13, 2012 AT 11:03 PM

Is there a way for me to do that myself. I have spent alot of money on bullshit tests as it is. Lol I have also installed a new fuel filter

Please login or register to post a reply.

Read Codes Like a Pro
 Step by Step video GMC Yukon XL 2000-2006
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear - Dodge Stratus