I USED A TEST LIGHT AND NO CURRENT IS GOING TO ...

1990 Chevrolet Cheyenne

Tiny

virgilderricott

February, 19, 2013 AT 11:50 PM

I used a test light and no current is going to my 2 two wire square conectors. On my 2 bullet shape fuel injectors. 4.3l v-6 engine. All fuses are good, installed a new electonic control module in distributor and fuel pump in tank runs good. Disconected fuel line plenty gas going to carb. Vehicle runs when gas is poured in manually. But can't get injectors to work. Please tell me what am I missing. Vehicle had been fine drove it up to my garage cut it off, afterwards wouldn't start anymore.

3 Answers

Tiny

JDL

February, 20, 2013 AT 12:05 AM

The voltage wires at the fuel injectors are red and white, probably goes hot with the key on. Any voltage on those wires? If not, have to go back to injector fuse. Even if the fuse is good, you still need to check voltage at fuse circuit, key on. Let us know what you find.

Tiny

virgilderricott

March, 16, 2013 AT 9:06 PM

Thanks very much I tested before with key on and while rotating engine. I will try again and check the injector fuse and voltage at the fuse circuit. With key on. Today is first time finding your reply answer to my question.

Tiny

JDL

March, 21, 2013 AT 2:53 PM

Let us know what you find.

Please login or register to post a reply.

Fuel Filter Replacement Ford Mustang
Fuel Filter Replacement Chevrolet Silverado
Fuel Filter Replacment BMW 525i
Fuel Filter Mount Replacement Chevrolet
Fuel Filter Replacement Ford Escape 2000-2006
Fuel Filter Replacement Chevrolet Silverado
Fuel Pump Replacement Ford Mustang