I am not getting any cold air from my A/C

Tiny
HOFF
  • MEMBER
  • 1989 NISSAN 240SX
  • 183 MILES
The night my a/c broke on my 89 nissan 240sx, I was driving home on the highway with the ac button on but the blower motor off. The day after the a/c was spotty and worked periodically threw the day then never worked again. Any chance I burned up the compressor? The system is r-12 ac was always ice cold accept for in the 95 degree heat because it was over powered.
Do you
have the same problem?
Yes
No
Thursday, December 8th, 2011 AT 3:15 AM

5 Replies

Tiny
SATURNTECH9
  • MEMBER
So is the blower motor inop or your ac inop?
Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 3:42 AM
Tiny
HOFF
  • MEMBER
Sorry about all the typo's the blower motor works and blows air but the air is no longer cold by any means. This was a sudden failure of the a/c it has always worked 100% ice cold
Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 4:04 AM
Tiny
SATURNTECH9
  • MEMBER
Then it sounds like you have a leak look for oil and dirt collected.
Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 4:12 AM
Tiny
KHLOW2008
  • EXPERT
Check to see if the compressor is cutting in.
Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 4:23 PM
Tiny
SATURNTECH9
  • MEMBER
Your also going to have to invest in some tools like a ac gauge set if your going to try to do this yourself.
Was this
answer
helpful?
Yes
No
Thursday, December 8th, 2011 AT 8:16 PM

Please login or register to post a reply.

Sponsored links