1989 Jeep Cherokee 1989 Jeep Cherokee

Tiny
ERIC DRAGON
  • MEMBER
  • 1989 JEEP CHEROKEE
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 157,000 MILES
All of a sudden the radio, power seats and rear defrost stopped working. Could this be a fuse thats went bad?
Do you
have the same problem?
Yes
No
Tuesday, April 27th, 2010 AT 6:33 PM

8 Replies

Tiny
RACEFAN966
  • EXPERT
Ok two things to look at first. The fuse box inside the jeep I need you to check the htd/wdw fuse 25 amp. Then check the pwr/acc circuit breaker 30 amp. Let me know what you find and we will go from there.
Was this
answer
helpful?
Yes
No
Thursday, April 29th, 2010 AT 9:18 AM
Tiny
JMFISHER
  • MEMBER
I have a similar lose of all acc equipment(no radio, ac, wipers.), All fuses are good and the jeep still runs. Can you tell me where this breaker is, or any other thoughts?
Was this
answer
helpful?
Yes
No
Sunday, October 16th, 2011 AT 1:39 AM
Tiny
CJ MEDEVAC
  • EXPERT
THIS IS ABOUT ALL I CAN OFFER

IMMA CJ GUY

FOLLOW ALL OF THE CABLES/ WIRES FROM THE POSITIVE SIDE OF YOUR BATTERYLOOSEN/ CLEAN/ TIGHTEN ANY AND ALL CONNECTIONS (FEEDS TO YOUR FUSE BOX(ES))

FIND ALL FUSE BOXES---UNDER HOOD--DASH, ENDS OF DASH ETC.

YOUR RIG IS NO WHERE NEAR AS OLD AS MY 2 "REAL JEEPS"---BUT IT DOES HAVE SOME AGE!

LET'S PULL OUT ALL FUSES THAT COULD BE RELATED, EVEN THE BIG ONES!

TAKE 'EM OUT AND RE-INSTALL THEM 3 OR 4 TIMES

WHY?

THEY GET A WHITE LOOKING COATING ON THE "LEGS" AND IN THE CONNECTORS, THIS IS "CORROSION". THIS WILL SORTA SCRAPE 'EM CLEAN

IF YOU REALLY LOVE YOUR JEEP, YOU WILL GET A TUBE OF DIELECTRIC GREASE AND COAT ALL OF THE ELECTRICAL ITEMS "CONNECTORS/ CONNECTIONS" THIS WILL ELIMINATE FUTURE PROBLEMS W/ OTHER STUFF TOO.A LIGHT SMEAR WILL DO!

THEN YOU MIGHT LOOK FOR BURNED UP "FUSIBLE LINKS".I MAY BE ABLE TO FIND LOCATIONS FOR THEM, IF YOU GET THIS INVOLVED, AND WE HOPE YOU ARE FIXED BEFORE THIS! (I HAVE ACCESS TO DIAGRAMS, IF NEED BE POST EXACT SPECS FOR YOUR BODY AND ENGINE, THIS HELPS ME GREATLY!)

KEEP US POSTED

THE MEDIC
Was this
answer
helpful?
Yes
No
+1
Sunday, October 16th, 2011 AT 3:18 AM
Tiny
JMFISHER
  • MEMBER
Thank you for a quick reply.

I have narrowed it down to the ignition switch(no power on the brown wire) form another post. Still looking at other possibilities, shorts, ect.

Is there more than one fuse panel on an 89 Cherokee?
Was this
answer
helpful?
Yes
No
Sunday, October 16th, 2011 AT 6:02 PM
Tiny
CJ MEDEVAC
  • EXPERT
IN MITCHELL I, I SEE ONE FUSE BOX

I THINK I FOUND ALL OF THE DIAGRAMS CONCERNING IGN SWITCH

I DON'T KNOW HOW THEY LOOK 'TILL I POST 'EM

THEY ARE "CRISP" IN MY DOWNLOADS

CAN'T SEE THE CRAMMED ONES WELL?

I'LL SEND YOU A MESSAGE, CONCERNING A SAFE WAY TO GET 'EM TO YOU

HOME>YOUR USER NAME>LOOK LEFT FOR "MESSAGES"

THE MEDIC
Was this
answer
helpful?
Yes
No
Sunday, October 16th, 2011 AT 8:54 PM
Tiny
CJ MEDEVAC
  • EXPERT
I HAVE TERRIBLE "CRS"

DID I GET YOU EVERYTHING YOU NEEDED?

IF NOT, SORRY, CAN I GET YOU OR SEND YOU ANYTHING ELSE?

I WAS GOING THRU MESSAGES, I DID NOT SEE A REPLY BACK TO YOU FROM ME

THE MEDIC
Was this
answer
helpful?
Yes
No
Friday, December 2nd, 2011 AT 5:45 PM
Tiny
JMFISHER
  • MEMBER
Yes, the problem appears to be fixed. The fan connector somehow got switched, and because it is hot wired to a switch from the fuse box, it was stealing power from my accessories.

Thank you again for you help.
Was this
answer
helpful?
Yes
No
Friday, December 2nd, 2011 AT 7:40 PM
Tiny
RIVERMIKERAT
  • MEMBER
Glad to help. Closing thread.
Was this
answer
helpful?
Yes
No
Friday, January 27th, 2012 AT 6:08 AM

Please login or register to post a reply.

Recommended Guides