I have 1989 GMC Sierra 1500 sle it has been.

Tiny
STEVENWHITE
  • MEMBER
  • 1989 GMC C1500
  • 166,000 MILES
I have 1989 gmc sierra 1500 sle it has been redone and now has a 350 small block with 4 speed tran. Auto ( bot this way). It cuts out while driving. Stalles while stopping, and idling. So far I replace IAC valve, ICM, Distributor cap and rotor, and coolant temp. Sensor. Still does the same thing. Also there is a loud sucking like noise coming from the engine. While this is happening, the injectors start acting up. Some times there is a engine light sometimes there is not. While the Light is on it seems to run ok but gas crazy. I had a mechanic look it and told me it was coolant temp sensor.

So my Question is: What could be causing this problem? Thanks.
Do you
have the same problem?
Yes
No
Friday, November 9th, 2012 AT 10:39 PM

2 Replies

Tiny
HMAC300
  • EXPERT
Spray some choke cleaner behind the tbi unit, they tend to blow the gasket beneath it there. Also you should scan for codes and check fuel pressure. If it's tbi it shold be 9-11 psi. Auto parts stores have the gauge and rent them out but check for the vacuum leak first, normally that's what it is.
Was this
answer
helpful?
Yes
No
Friday, November 9th, 2012 AT 11:09 PM
Tiny
STEVENWHITE
  • MEMBER
Thanks. I also forgot to mention that I put a tuneup kit on the whole throttle body.
Was this
answer
helpful?
Yes
No
Saturday, November 10th, 2012 AT 6:10 AM

Please login or register to post a reply.

Recommended Guides