Ideling problems

Tiny
MTM0912
  • 1989 CHEVROLET CAPRICE
  • 100,000 MILES

I have a 1989 chevrolet caprice that sat for about 6 months. I have replaced the spark plugs, wires, fuel pump, idel control valve, tps sensor. The problem is when it starts up when it is cold it runs fine, but when it warms up, like the choke goes off, it won't idel and stalls out. It is a 305V8 with fuel injection on it. When I start it back up after it stalls out and hold the gas down it will run perfect, just won't idel.

Do you
have the same problem?
Yes
No
Thursday, June 28th, 2012 AT 1:09 AM

4 Replies

Tiny
DRCRANKNWRENCH
  • EXPERT
  • 3,447 POSTS

When gas sits it turns to a varnish in about a month or so. The fuel injectors and/or the fuel filter are probably clogged. You can get some SEA FOAM and pour it into the vacuum tube of the power brake assist and see if that helps as well as replacing the fuel filter and the gas in the tank.

Was this
answer
helpful?
Yes
No
Thursday, June 28th, 2012 AT 1:13 AM
Tiny
MTM0912
  • MEMBER

Fuel filter also replaced and the injectors look like they are spraying perfect, there aren't any funny lines of gas shooting out, just sprays in a circle.

Was this
answer
helpful?
Yes
No
Thursday, June 28th, 2012 AT 1:17 AM
Tiny
MTM0912
  • MEMBER

Gas also taken out and fresh gas in tank.

Was this
answer
helpful?
Yes
No
Thursday, June 28th, 2012 AT 1:19 AM
Tiny
DOCDTC
  • EXPERT
  • 54 POSTS

Check the coolant temp sensor, possibly connection/ possibly sensor. If the ECM sees open on the sensor input, it will default to -40 f. This would cause the condition you describe. Hope this was helpful, Doc

Was this
answer
helpful?
Yes
No
Thursday, June 28th, 2012 AT 1:45 AM

Please login or register to post a reply.

Related Spark Plug Replace/Remove Questions

Recommended articles