1989 Chevy Caprice electrical issue

Tiny
JB BRUNO
  • MEMBER
  • 1989 CHEVROLET CAPRICE
  • V8
  • 2WD
  • AUTOMATIC
  • 204,446 MILES
Hi
1989 Caprice put new battery and new starter in car.
Headlights, running lights, interior lights, blower motor and dash lights will not illuminate.
All fuses are ok and have been checked.
What gives?
Do you
have the same problem?
Yes
No
Friday, March 18th, 2011 AT 3:45 PM

8 Replies

Tiny
JDL
  • EXPERT
Did you use a voltage tester at the applicable fuses? Even if the fuse is good, if there is no voltage, the circuit is dead.

Check the circuits at the headlamp switch. The voltage just for the headlamps, comes from fusible link, there is a circuit breaker in the switch assembly for headlamps. Other lamps that are controled by the headlamp switch are fuse protected. Note info below.
Was this
answer
helpful?
Yes
No
Friday, March 18th, 2011 AT 4:17 PM
Tiny
RN1944
  • MEMBER
Headlight switch was replaced (which might be bad - aftermarketstuff - not AC Delco)), but continuing on it still has loss of dash, dome, and tailights too? Any ideas? Thanks - RAY. PS: there is a module / relay for the dash/headlights somewhere behing dash - location unknown@
Was this
answer
helpful?
Yes
No
-1
Friday, November 25th, 2011 AT 1:26 PM
Tiny
RN1944
  • MEMBER
No reply came through from last question! I stated that switch was replaced(aftermarket-not AC Delco) but no luck and still no other lihts (IE: dash, dome interior, and taillights - only bacjuk lights work! Any ideas? Thanks - RAY
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 1:36 PM
Tiny
RN1944
  • MEMBER
Still waiting on somemore input )another answer to my problem question?
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 1:43 PM
Tiny
JDL
  • EXPERT
So your headlamps are working ok? Did you check for voltage at tail-lamps fuse? You may need to check all your fusible links.
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 4:23 PM
Tiny
RN1944
  • MEMBER
Somewhere I dropped the ball! - My bad! I forgot to list that all lights: headlights, taillights, dash, dome, parking are "Not Working"! The only lights that are working are the back-up lights!
I hope that clarifies my explanation clearly this time around - as I think originally I did also list the headlights as not-working, but due to answering replies a few times I somehow missed listing those headlights - TOO! Sorry Regards - RAY
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 5:34 PM
Tiny
RN1944
  • MEMBER
Headlights are also "Not Working" - which I missed listing - since I had to answer replies so many times to explain the situation! Thank You - RAY! Still at this time I do not have a direct solution on what to do to fix this problem! Thanks - RAY
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 5:39 PM
Tiny
JDL
  • EXPERT
I gave you an answer on march 18th, you waited till nov 25th to reply? I gave you a wiring diagram, did you check for voltage, anywhere?
Was this
answer
helpful?
Yes
No
Friday, November 25th, 2011 AT 5:48 PM

Please login or register to post a reply.

Recommended Guides